>From ac790dd221a774b9f6dda7b924a74c0d3a673514 Mon Sep 17 00:00:00 2001 From: Paul Eggert Date: Sat, 11 May 2019 09:32:04 -0700 Subject: [PATCH 2/4] maint: adjust to recent verify_true removal * src/system.h (X2NREALLOC, X2REALLOC, DECIMAL_DIGIT_ACCUMULATE): Use verify_expr instead of verify_true, which has been removed. (DECIMAL_DIGIT_ACCUMULATE): Remove unnecessary size check. --- src/system.h | 18 +++++++++--------- 1 file changed, 9 insertions(+), 9 deletions(-) diff --git a/src/system.h b/src/system.h index e4790f7cc..65cd742fc 100644 --- a/src/system.h +++ b/src/system.h @@ -245,15 +245,15 @@ uid_t getuid (void); the third argument to x2nrealloc would be 'sizeof *(P)'. Ensure that sizeof *(P) is *not* 1. In that case, it'd be better to use X2REALLOC, although not strictly necessary. */ -#define X2NREALLOC(P, PN) ((void) verify_true (sizeof *(P) != 1), \ - x2nrealloc (P, PN, sizeof *(P))) +#define X2NREALLOC(P, PN) verify_expr (sizeof *(P) != 1, \ + x2nrealloc (P, PN, sizeof *(P))) /* Using x2realloc (when appropriate) usually makes your code more readable than using x2nrealloc, but it also makes it so your code will malfunction if sizeof *(P) ever becomes 2 or greater. So use this macro instead of using x2realloc directly. */ -#define X2REALLOC(P, PN) ((void) verify_true (sizeof *(P) == 1), \ - x2realloc (P, PN)) +#define X2REALLOC(P, PN) verify_expr (sizeof *(P) == 1, \ + x2realloc (P, PN)) #include "unlocked-io.h" #include "same-inode.h" @@ -567,11 +567,11 @@ is_nul (void const *buf, size_t length) #define DECIMAL_DIGIT_ACCUMULATE(Accum, Digit_val, Type) \ ( \ (void) (&(Accum) == (Type *) NULL), /* The type matches. */ \ - (void) verify_true (! TYPE_SIGNED (Type)), /* The type is unsigned. */ \ - (void) verify_true (sizeof (Accum) == sizeof (Type)), /* Added check. */ \ - (((Type) -1 / 10 < (Accum) \ - || (Type) ((Accum) * 10 + (Digit_val)) < (Accum)) \ - ? false : (((Accum) = (Accum) * 10 + (Digit_val)), true)) \ + verify_expr (! TYPE_SIGNED (Type), /* The type is unsigned. */ \ + (((Type) -1 / 10 < (Accum) \ + || (Type) ((Accum) * 10 + (Digit_val)) < (Accum)) \ + ? false \ + : (((Accum) = (Accum) * 10 + (Digit_val)), true))) \ ) static inline void -- 2.21.0