[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#14767: du -s reports Infinity

From: Marek Otahal
Subject: bug#14767: du -s reports Infinity
Date: Tue, 23 Jul 2013 23:35:26 +0200

Hi, thanks for advice and sorry for the delay, I went in wilderness off the

On Wed, Jul 3, 2013 at 12:10 AM, Paul Eggert <address@hidden> wrote:

> On 07/02/2013 01:26 PM, Marek Otahal wrote:
> > newfstatat(AT_FDCWD,
> > ".kde4/share/apps/kopete/logs/JabberProtocol/address@hidden
> > /address@hidden", {st_mode=S_IFREG|0644,
> st_size=2576,
> > ...}, AT_SYMLINK_NOFOLLOW) = 0
> This is one of the key system calls, but it's lacking
> crucial details.  What does strace -v say for that syscall?
> strace -v should give info about st_blksize and st_blocks.
it reports:

$ strace -v du
/address@hidden 2>&1  | grep newfstatat
/address@hidden", {st_dev=makedev(0, 40), st_ino=6369,
st_mode=S_IFREG|0644, st_nlink=1, st_uid=1000, st_gid=100, st_blksize=4096,
st_blocks=36028797018963952, st_size=2576, st_atime=2013/03/11-21:56:17,
st_mtime=2013/03/11-21:56:17, st_ctime=2013/03/11-21:56:17},

it reports lots of blocks (btw, i tried defrag in btrfs before).

Regarding running fsck, well, it's btrfs, so the fsck is not so matured
yet...what can i run for testing? Yet, no errors with the FS are
..it must have been a FS corruption, a cp -a (to /tmp on tmpfs), rm, and cp
-a back cycle solved it.

$  strace -v du  ~/.kde4/share/apps/kopete/logs/JabberProtocol/....
newfstatat(AT_FDCWD, ....., {st_dev=makedev(0, 40), st_ino=569698,
st_mode=S_IFREG|0644, st_nlink=1, st_uid=1000, st_gid=100, st_blksize=4096,
st_blocks=8, st_size=2576, st_atime=2013/03/11-21:56:17,
st_mtime=2013/03/11-21:56:17, st_ctime=2013/07/23-23:30:07},

Guys, sorry for the false alarm, and thanks for guidance here!
With best regards, Mark

Marek Otahal :o)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]