[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

coreutils on interix: mods to savewd.c and who.c

From: Martin Koeppe
Subject: coreutils on interix: mods to savewd.c and who.c
Date: Sun, 16 Sep 2007 12:38:38 +0200 (CEST)

Hi all,

I just tried to build coreutils (6.10pre20070907 from Debian) on interix.

The first thing I encountered is the "cannot read mounted file systems" issue. I changed configure.ac to only warn about that. Nevertheless, compilation of df.c was automatically disabled, so apparently coreutils can handle this already.

The next thing is savewd.c, which requires errno value ESTALE to be there, but interix doesn't have that one. The third is who.c, which doesn't check for IPV6 (interix doesn't have IPV6). For these you'll find a patch attached.

Another issue: I first tried to configure with --enable-no-install-program=who, but nevertheless who.c is tried to be built. Shouldn't --enable-no-install-program also disable compilation of who.c? One might try to disable it, because it doesn't build :-)

After these patches the build went through, but "make check" doesn't:

Making check in man
make[2]: Entering directory `/tmp/coreutils-6.10~20070907/man'
/usr/bin/make  check-local
make[3]: Entering directory `/tmp/coreutils-6.10~20070907/man'
PATH=../src:$PATH; export PATH;         \
        t=ls-files.$$;                                          \
        (cd . && ls -1 *.x) | sed 's/\.x$//' | LC_ALL=C sort > $t;\
        (echo groups.1 uname.1 chroot.1 nice.1 who.1 users.1 [... 8<]
          | tr -s ' ' '\n' | sed 's/\.1$//')       \
          | LC_ALL=C sort -u | diff - $t || { rm $t; exit 1; };  \
        rm $t
make[3]: *** [check-x-vs-1] Error 1

df.c and hostid.c weren't tried to compile. I didn't look into the details of this one, but simply disabled the whole check for now.


Attachment: coreutils-interix.diff
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]