[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug in the DF application...

From: Ryan Ashley
Subject: Bug in the DF application...
Date: Sun, 2 Apr 2006 21:45:27 -0400

Alright, I've been using Debian for ages, and never ran across something
like this.  It makes me wonder if it is affecting other programs on the
system as well.  I installed GCC tonight and in the process it had to
upgrade libc6.  It upgraded properly, and when it finished I rebooted the
machine just to play it safe.  After it came back up I checked my free space
and got this:
Primary:~# df -ah
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda1            -405370878767k  1.0k  0.0k   9% /
proc                   -0k  0.0k  0.0k   -  /proc
/dev/hda2            -136628747263k  1.0k  0.0k  21% /var
/dev/hda3            -1900499642371k  1.0k  0.0k  48% /home
Clearly, the size is being reported wrong.  Prior to the upgrade of libc6,
it worked fine and reported in megabytes.  I tried using "df -ahm" and it
reported negative megabytes.  I even went as far as upgrading everything on
the system using apt, and the problem still exists.  Is there a fix for this
or is it time to find somewhere to store /home, then format and reinstall?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]