bug-commoncpp
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Rearranging source files


From: Marc Boris Dürner
Subject: Re: Rearranging source files
Date: Fri, 2 Jan 2004 16:36:48 +0100 (MET)

Hi, 
The split is definatley material for a later version. I found an old
common-c++ sourceforge 
website and there the library was even more modularised. 
 
http://cplusplus.sourceforge.net/ 
 
There is says: 
libcc++ 
libccstd 
libccio 
 
Dont know if this still makes sense. How would you like to do it? 
 
This is what I have right now(each.cpp complemented by a .h file of the same
name): 
 
libccnet_la_SOURCES = BroadcastAddress.cpp \ 
        InetAddress.cpp \ 
        InetHostAddress.cpp \ 
        InetMaskAddress.cpp \ 
        InetMcastAddress.cpp \ 
        NetworkDeviceInfo.cpp \ 
        SimpleTCPStream.cpp \ 
        Socket.cpp \ 
        SocketPort.cpp \ 
        SocketService.cpp \ 
        TCPSession.cpp \ 
        TCPSocket.cpp \ 
        TCPStream.cpp \ 
        UDPBroadcast.cpp \ 
        UDPDuplex.cpp \ 
        UDPReceive.cpp \ 
        UDPSocket.cpp \ 
        UDPTransmit.cpp \ 
        URLStream.cpp \ 
        UnixSession.cpp \ 
        UnixSocket.cpp \ 
        UnixStream.cpp \ 
        UrlString.cpp \ 
        WSA.cpp \ 
        tcpstream.cpp \ 
        unixstream.cpp 
 
All the other classes are in libccbase. But I havent split the source files
yet(This is quite a 
bit of work...). 
 
hope I am useful, 
Marc 
 
 
> While it sounds like the right thing to do, this sounds like it should be 
> introduced in an active release after 1.1, perhaps for "1.2".  1.1 still 
> has fairly limited changes that don't break most peoples existing
projects, 
> while this could... 
> 
> On Thursday 01 January 2004 08:08 pm, Marc Boris Dürner wrote: 
> > I have started (almost done actually) to separate the networking code 
> > from the base 
> > library to form a library called ccNet. Normally one class per .h/.cpp 
> > pair, except for 
> > exception classes or the validator classes. 
> > 
> > Is there anything else we can modularise? 
> > 
> > I wasnt sure what the extension library is, but it seemed pretty generic

> > to me. I have put 
> > these classes in the base lib for now. 
> > 
> > Any thought on a naming scheme? ccNet seemed like the logical choice 
> > (ccAudio, 
> > ccScript... already exist). How shall we call the base lib? libccBase?
or 
> > just libcc? 
> > 
> > How about the namespace Gnu::? after all this is an official gnu
project, 
> > isnt it? 
> > 
> > 
> > Marc 

-- 
+++ GMX - die erste Adresse für Mail, Message, More +++
Neu: Preissenkung für MMS und FreeMMS! http://www.gmx.net






reply via email to

[Prev in Thread] Current Thread [Next in Thread]