[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#37499: Wrong location of deps directory when using AC_SUBST

From: Karl Berry
Subject: bug#37499: Wrong location of deps directory when using AC_SUBST
Date: Mon, 23 Nov 2020 19:06:52 -0700

Hi Fabrizio - sorry for the absurdly delayed reply.
Also sorry, but I don't exactly understand.

    dnl Use absolute path of lib
    MYLIB_PATH=`readlink -f ${MYLIB_PATH}`
    testApp_SOURCES = main.c @MYLIB_PATH@/mylib_log.c
    testApp_CFLAGS = -I@MYLIB_PATH@/lib
    After running configure, I get the .deps directory created here:

Are you saying an older version used to not insert the full directory
path when making the .deps? So that it ended up being (I guess):
Do you know what version worked?

If it worked with an older version and doesn't work now, I could try to
look. Otherwise it is hard to guess what could have changed. My first
reaction is that automake is just using the path it's given; I wouldn't
expect it to the relativization itself? I suspect I'm misunderstanding

    I have a full reproducible project I could attach. Just let me know.

For sure a reproducible case would be helpful in understanding. The
smaller the better.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]