[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-apl] Segmentation fault causes GNU APL version 1.5-1 AMD64 to e

From: Juergen Sauermann
Subject: Re: [Bug-apl] Segmentation fault causes GNU APL version 1.5-1 AMD64 to exit
Date: Sat, 02 Jan 2016 14:55:47 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Thunderbird/31.4.0


I am currently trying to reproduce the fault, but was not yet able to.
Like in Blake's case, 1500x1500 worked on my machine.
I am currently trying 4000x4000 but that hasn't finished yet (takes ages).

The _expression_ that I am using is:


Rick, I suppose you can reproduce the fault more easily. Please try the

1. in the GNU APL src directory, start gdb with GNU APL:

gdb ./apl


2. after the segfault has occurred, print the backtrace (still in gdb):


Thanks a lot,

On 01/02/2016 02:39 PM, Blake McBride wrote:
Just for reference, I tried your example with the head of the source code repository, and I got:

$ apl
      a←1500 1500⍴?(1500×1500)⍴10

However, since your  ⎕wa was substantially less than mine, it may be that you ran out of RAM and I didn't.

Also, what version of the GNU APL source code did you start with?  (The repository head is highly recommended.)

Hope this helps.

Blake McBride

On Fri, Jan 1, 2016 at 2:03 PM, Rick Mayforth <address@hidden> wrote:

The following sequence caused the fault. APL exits. The interpreter is running under Debian 8 in a VMWare virtual machine with 2GB RAM & 880MB swap space. One would expect a WS FULL or some other APL error in this instance rather than a forced exit, no?

a←1500 1500 ⍴ ?(1500×1500)⍴10
Segmentation fault

reply via email to

[Prev in Thread] Current Thread [Next in Thread]