[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-apl] Strange output from configure

From: Blake McBride
Subject: Re: [Bug-apl] Strange output from configure
Date: Fri, 6 Mar 2015 10:55:04 -0600

I checked around and found:

1.  I have a clean checkout of gnu-apl in ~blake/Backup/apl (the build directory)

2.  There is an executable file named 'missing' in that build directory.

3.  I am running ./configure from the build directory

4.  I still get the same error.  Interestingly, the error states that /home/blake/missing is missing.  /home/blake is neither where the build directory is nor where I am running configure from.



On Fri, Mar 6, 2015 at 10:46 AM, Juergen Sauermann <address@hidden> wrote:
Hi Blake,

'missing' is a script provided by autoconf.

It is normally contained in the SVN checkout and also in the GNU APL tar file.
The message below suggests that it was somehow deleted. The normal place
for it is the same directory as configure and configure.ac.

So my question 1 would be: is it missing or too old?
If your top-level GNU APL directory is
/home/blake (which would be a little strange)
then it is in fact missing.

If you have automake installed (you don't need to) then you can re-create missing with 'automake -a'

It could as well be that I should update my 'missing' file since my old machine broke down and the new one
most likely has a different automake version.

Or maybe you just ran ./configure in the wrong directory?

/// Jürgen

On 03/06/2015 02:52 PM, Blake McBride wrote:
When I run ./configure I am getting:

checking for unistd.h... yes
checking minix/config.h usability... no
checking minix/config.h presence... no
checking for minix/config.h... no
checking whether it is safe to define __EXTENSIONS__... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/bin/bash: /home/blake/missing: No such file or directory
configure: WARNING: 'missing' script is too old or missing
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk

From above, what does the following mean?

/bin/bash: /home/blake/missing: No such file or directory
configure: WARNING: 'missing' script is too old or missing



reply via email to

[Prev in Thread] Current Thread [Next in Thread]