[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] Re: changes

From: Waldek Hebisch
Subject: [Axiom-developer] Re: changes
Date: Tue, 22 May 2007 00:09:55 +0200 (CEST)

> re: hyper missing
> ok. i've fixed the missing hyper directory on svn. it's rather curious
> because the git and svn versions came from the same source tree. the
> git version properly checked in the hyper directory but svn did
> not. most everything else got checked in.... how very curious.

I updated the svn and tried to build it.  Note that I am working on
the copy of the SVN tree.  The machine is 64-bit Debian.

I run configure first:

address@hidden:~/ax-daly/axiom$ ./configure

You must set your AXIOM and PATH variables. Type:

To build the rest of the system type:

export AXIOM=/h/ax-daly/axiom/mnt/linux
export PATH=$AXIOM/bin:$PATH

configure finished.

Ok, so I proceed as instructed:

address@hidden:~/ax-daly/axiom$ (export AXIOM=/h/ax-daly/axiom/mnt/linux; export
 PATH=$AXIOM/bin:$PATH; make)
13 making noweb

a lot of noise which looks OK.  But then the build stops:

make[1]: Wejście do katalogu `/h/ax-daly/axiom'
11 checking directory structure
12 Environment: PLF=LINUXplatform CCF=-O2 -fno-strength-reduce -Wall 
-D_GNU_SOURCE -DLINUXplatform -I/usr/X11/include LDF= -L/usr/X11R6/lib 
/usr/X11R6/lib/libXpm.a  CC=gcc AWK=gawk RANLIB=ranlib TOUCH=touch TAR=tar 
AXIOMXLROOT=/h/ax-daly/axiom/mnt/linux/compiler O=o BYE=bye LISP=lsp 
DAASE=/h/ax-daly/axiom/src/share XLIB=/usr/X11R6/lib 
GCLOPTS=--enable-vssize=65536*2 --enable-locbfd --disable-dynsysbfd 
--disable-statsysbfd --enable-maxpage=256*1024 --disable-xgcl 
--disable-tkconfig SRCDIRS=bootdir interpdir sharedir algebradir etcdir clefdir 
docdir graphdir smandir hyperdir inputdir  PATCH=patch
cp: nie można utworzyć zwykłego pliku 
`/h/ax-daly/axiom/mnt/linux/bin/tex/.svn/README.txt': Brak dostępu
cp: nie można utworzyć zwykłego pliku 
`/h/ax-daly/axiom/mnt/linux/bin/tex/.svn/wcprops/axiom.sty.svn-work': Brak 
cp: nie można utworzyć zwykłego pliku 
`/h/ax-daly/axiom/mnt/linux/bin/tex/.svn/format': Brak dostępu

The error message is in Polish, translated says: cannot create ordinary
file ...: Permission denied

This problem should be very easy to fix, but do you think it makes sense
to work solving already solved (by Gaby) problem?

                              Waldek Hebisch

reply via email to

[Prev in Thread] Current Thread [Next in Thread]