[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Axiom-developer] AxiomUI code update

From: Page, Bill
Subject: RE: [Axiom-developer] AxiomUI code update
Date: Wed, 17 Aug 2005 18:44:53 -0400


In your axiomui/README file you wrote:

> ...
> If you use Windows the software should work, but
> I can't tell you how to start it. Look at,
> run.lisp and axiom-hub.lisp for further info.

So I thought I would give it a try. First I installed
clisp-2.34 in a directory path with no spaces c:\clisp-2.34.
I added c:\clisp-2.34 to the executables PATH and made sure
that I could run in from the MSDOS command line.

I extracted your
to c:\axiomui. Then I modified the to the following
run.bat file:

  set AXIOMUI_STATIC_PAGES="C:\axiomui\static-pages"
  clisp -norc -i run.lisp


Typing 'run' produced the following result:


C:\axiomui>set AXIOMUI_STATIC_PAGES="C:\axiomui\static-pages"

C:\axiomui>clisp -norc -i run.lisp
  i i i i i i i       ooooo    o        ooooooo   ooooo   ooooo
  I I I I I I I      8     8   8           8     8     o  8    8
  I  \ `+' /  I      8         8           8     8        8    8
   \  `-+-'  /       8         8           8      ooooo   8oooo
    `-__|__-'        8         8           8           8  8
        |            8     o   8           8     o     8  8
  ------+------       ooooo    8oooooo  ooo8ooo   ooooo   8

Copyright (c) Bruno Haible, Michael Stoll 1992, 1993
Copyright (c) Bruno Haible, Marcus Daniels 1994-1997
Copyright (c) Bruno Haible, Pierpaolo Bernardi, Sam Steingold 1998
Copyright (c) Bruno Haible, Sam Steingold 1999-2000
Copyright (c) Sam Steingold, Bruno Haible 2001-2005

;; Loading file C:\axiomui\run.lisp ...
;;  Loading file C:\axiomui\asdf.lisp ...
;;  Loaded file C:\axiomui\asdf.lisp
*** - component "axiom-hub" not found
The following restarts are available:
SKIP           :R1      skip this form and proceed
STOP           :R2      stop loading file
ABORT          :R3      ABORT
Break 1 [2]>


There seems to be something a little non-portable involving
paths and/or component names in Windows vs. Linux.

In run.lisp you wrote:

  (push #P"." asdf:*central-registry*)

Perhaps you need something involving (truename ".")
which returns a real Windows path?

But I don't know enough about clisp on Windows to really
Suggest what might be going wrong here.

Thanks for your hard work!

Bill Page.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]