[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Axiom-developer] [#33 GCL fails to compile on Fedora Core 3] (new)

From: anonymous
Subject: [Axiom-developer] [#33 GCL fails to compile on Fedora Core 3] (new)
Date: Tue, 18 Jan 2005 22:47:11 -0600

Has anyone gotten GCL to run on Fedora Core 3?


------- Start of forwarded message -------
Subject: magnus and axiom questions
From: Chuck Miller <address@hidden>
To: address@hidden
Date: Thu, 13 Jan 2005 08:27:37 +1100

Hi Tim,

I have acquired PC laptop (dell latitude d600) running dual boot
with Windows XP Pro (rarely) and Fedora Core 3 (most of the time).
My general intention is to help you bring magnus into a useable
atate since I think there is some useful stuff there that shouldn't
be lost.


I also tried to compile axiom - and gcl of course - but the gcl
part fails as follows (both 2.6.2 and 2.6.5):

gcc -c -Wall -DVOL=volatile -fsigned-char -pipe -O3 -fomit-frame-pointer
- -I/home/cfm/axiom-dev/axiom/lsp/gcl-2.6.5/o -I../h -I../gcl-tk sfasl.c
In file included from sfasl.c:40:
sfaslbfd.c: In function `fasload':
sfaslbfd.c:266: error: structure has no member named `_raw_size'
sfaslbfd.c:291: error: structure has no member named `_raw_size'
sfaslbfd.c:356: error: structure has no member named `_raw_size'
make[4]: *** [sfasl.o] Error 1
make[4]: Leaving directory `/home/cfm/axiom-dev/axiom/lsp/gcl-2.6.5/o'

I get the same error when I try to compile gcl separately.
The "_raw_size" should be "rawsize" according to the header files
but when I try to make this change to sfaslbfd.c and continue,
the original sfaslbfd.c gets restored by the tyrannical make process.

So I am mystified as to how one can get gcl and axiom to compile.

All help and suggestions welcome.

forwarded from

reply via email to

[Prev in Thread] Current Thread [Next in Thread]