avr-libc-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[avr-libc-commit] [2418] bug #42084: update LFUSE_DEFAULT in iotn84a.h a


From: Pitchumani
Subject: [avr-libc-commit] [2418] bug #42084: update LFUSE_DEFAULT in iotn84a.h as per datasheet
Date: Wed, 16 Apr 2014 11:43:43 +0000

Revision: 2418
          http://svn.sv.gnu.org/viewvc/?view=rev&root=avr-libc&revision=2418
Author:   pitchumani
Date:     2014-04-16 11:43:43 +0000 (Wed, 16 Apr 2014)
Log Message:
-----------
bug #42084: update LFUSE_DEFAULT in iotn84a.h as per datasheet

Ticket Links:
------------
    http://savannah.gnu.org/bugs/?42084

Modified Paths:
--------------
    trunk/avr-libc/ChangeLog
    trunk/avr-libc/NEWS
    trunk/avr-libc/include/avr/iotn84a.h

Modified: trunk/avr-libc/ChangeLog
===================================================================
--- trunk/avr-libc/ChangeLog    2014-04-16 11:34:47 UTC (rev 2417)
+++ trunk/avr-libc/ChangeLog    2014-04-16 11:43:43 UTC (rev 2418)
@@ -1,5 +1,11 @@
 2014-04-16  Pitchumani Sivanupandi <address@hidden>
 
+       Fix for bug #42084: wrong LFUSE_DEFAULT in iotn84a.h
+       Submitted by ralphdoncaster
+       * include/avr/iotn84a.h: Update LFUSE_DEFAULT as per datasheet.
+
+2014-04-16  Pitchumani Sivanupandi <address@hidden>
+
        Fix for bug #42085: HFUSE_DEFAULT not defined for iotn84.h
        Submitted by ralphdoncaster
        * include/avr/iotn84.h: Rename FUSE_HFUSE_DEFAULT to HFUSE_DEFAULT.

Modified: trunk/avr-libc/NEWS
===================================================================
--- trunk/avr-libc/NEWS 2014-04-16 11:34:47 UTC (rev 2417)
+++ trunk/avr-libc/NEWS 2014-04-16 11:43:43 UTC (rev 2418)
@@ -20,6 +20,7 @@
   [#40567] Invalid names in iotn13a.h (EEPE/EEMPE/BODS/BODSE)
   [#40595] iotn2313a.h: wrong fuses definitions for High Fuse Byte
   [#41519] wrong SPM_PAGESIZE definition in iotn[48]8.h
+  [#42084] wrong LFUSE_DEFAULT in iotn84a.h
   [#42085] HFUSE_DEFAULT not defined for iotn84.h
   [no-id]  XXX_vect_num not consistent io90pwmx.h, iousbxx6_7.h
   [no-id]  Specialize clock_prescale_set/get for mega hvb devices

Modified: trunk/avr-libc/include/avr/iotn84a.h
===================================================================
--- trunk/avr-libc/include/avr/iotn84a.h        2014-04-16 11:34:47 UTC (rev 
2417)
+++ trunk/avr-libc/include/avr/iotn84a.h        2014-04-16 11:43:43 UTC (rev 
2418)
@@ -605,7 +605,7 @@
 #define FUSE_SUT1  (unsigned char)~_BV(5)  /* Select start-up time */
 #define FUSE_CKOUT  (unsigned char)~_BV(6)  /* Clock Output Enable */
 #define FUSE_CKDIV8  (unsigned char)~_BV(7)  /* Divide clock by 8 */
-#define LFUSE_DEFAULT (FUSE_CKSEL0 & FUSE_CKSEL2 & FUSE_SUT0 & FUSE_CKDIV8)
+#define LFUSE_DEFAULT (FUSE_CKSEL0 & FUSE_CKSEL2 & FUSE_CKSEL3 & FUSE_SUT0 & 
FUSE_CKDIV8)
 
 /* High Fuse Byte */
 #define FUSE_BODLEVEL0  (unsigned char)~_BV(0)  /* Brown-out Detector trigger 
level */




reply via email to

[Prev in Thread] Current Thread [Next in Thread]