[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: aclocal only picking up /usr/local/share and not /usr/share

From: Maynard Johnson
Subject: Re: aclocal only picking up /usr/local/share and not /usr/share
Date: Thu, 17 Mar 2011 09:39:26 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20110303 Thunderbird/3.1.9

On 03/17/2011 5:17 AM, Stefano Lattarini wrote:
[adding automake-patches]

On Thursday 17 March 2011, Maynard Johnson wrote:
I have installed a version of aclocal into /usr/local that's newer
than my distro's version (I needed a fix from the newer version).
But then I ran into a problem recently where the build of some
package was failing because aclocal was not finding the pkgcfg.m4
file in /usr/share/aclocal.
I created a dirlist in /usr/local/share/aclocal and added
/usr/share/aclocal to it. That did indeed resolve the problem.
But is that the best way to resolve this problem?

IMO, if you have control on the installation of the aclocal you are
using, this is the right fix (and the one I'd suggest and use in your

Maybe this is documented somewhere,


If you think that's not clear enough, remember that suggestions and
costructive criticism are always welcome!

But then I have to say, the page above is admittetdly not easy to find,
being indexed with the incompete title "Scanning or".  Ralf, what about the attached patch (for maint)?
Maynard, are you OK with being added to the THANKS file?

and I just didn't see it, but it took me longer than I care to
admit to resolve this.  Seems like it could be a fairly common
problem.  Have others solved it in a more clever way rather
than telling system owners they need to create a new dirlist
if they've installed aclocal in a non-standard location?

Well, you could always resort to adding proper `-I' option to
you aclocal calls.  Also, in the next automake release, aclocal
will probably support a new 'ACLOCAL_PATH' environment variable
that would help solving this kind of problems
Except this happens when building a 3rd party package. Yes, I have the source for that package, and, in fact, the first fix I did was to update it's (where aclocal is called) to add '-I /usr/share/aclocal'. But that didn't seem like the right way to go either for the general case (i.e., I don't think that's an appropriate fix to contribute back to the package maintainer). I think the best I can do is to suggest an FAQ on that package's web site that documents the error and the solution.

Thanks for your response.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]