[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: rb5: remove combinatorial explosion patch

From: Richard Boulton
Subject: Re: rb5: remove combinatorial explosion patch
Date: Fri, 10 Aug 2001 00:14:27 +0100
User-agent: Mutt/1.2.5i

On Thu, Aug 09, 2001 at 03:07:04PM -0500, Raja R Harinath wrote:
> Hi,
> Richard Boulton <address@hidden> writes:
> [snip]
> >+    (variable_conditions_nonrecursive): New function.
> >+    (variable_value_as_list_nonrecursive): New function.
> I think the first would be better named as 'variable_direct_conditions'. 
> The second could be 'variable_direct_value_as_list', or
> 'variable_unexpanded_value_as_list'.

I agree that the names of these functions aren't wonderful.  I definitely
think they should be consistent though (ie, having one with "direct" and
one with "unexpanded" would be bad).

If I was writing from scratch, I'd simply call them "variable_conditions"
and "variable_value_as_list", and add "_recursive" to the other variants
(ie, the existing methods with those names).

Perhaps that would be the best thing to do even now: it would emphasise
that these functions can end up doing a lot of work and using a lot of
resources, and when they finally get deprecated the naming would be
simple and sensible.

I do think the word "recursive" is the best word to put in these function
names.  What else clearly conveys that they recurse through the

Actually, I think the dodgiest name I chose was


reply via email to

[Prev in Thread] Current Thread [Next in Thread]