[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: documentation through doxygen stopped working

From: Russ Allbery
Subject: Re: documentation through doxygen stopped working
Date: Tue, 03 Mar 2009 13:58:53 -0800
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)

Ralf Wildenhues <address@hidden> writes:

> That smells of M4 overquoting somewhere.  Find out what changed, the
> Autoconf version, or any third-party macro code, or  In
> case of doubt, please post a small example to reproduce the above
> together with a pointer to the exact DX_REQUIRE_PROG macro
> implementation.

I just ran into the same thing when going from Autoconf 2.61 to 2.63.  The
error message from Autoconf 2.63 is:

autoreconf --force
acinclude.m4:57: warning: underquoted definition of YAD_CHECK_INCLUDE_LIB
acinclude.m4:57:   run info '(automake)Extending aclocal'
acinclude.m4:57:   or see error: AC_SUBST: `DX_FLAG_[]DX_CURRENT_FEATURE' is not a valid 
shell variable name
doxygen.m4:77: DX_REQUIRE_PROG is expanded from...
doxygen.m4:117: DX_ARG_ABLE is expanded from...
doxygen.m4:178: DX_INIT_DOXYGEN is expanded from... the top level
autom4te: /usr/bin/m4 failed with exit status: 1

The same files worked without complaint with Autoconf 2.61, so it was some
change between 2.61 and 2.63 that revealed the problem.  (I suspect the
third-party macro file was always buggy.)  The macro is invoked via:


# ...

DX_INIT_DOXYGEN(shibboleth, doxygen.cfg, doc/api)

I'm attacking doxygen.m4.  (This is not my package, just one where I have
to patch and hence regenerate configure.)

I haven't had a chance to try fixing it yet, so haven't tried any of the
obvious bits.

Russ Allbery (address@hidden)             <>

Attachment: doxygen.m4
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]