[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: AS_ECHO calls finding their way into calls

From: Dmitriy Kargapolov
Subject: Re: AS_ECHO calls finding their way into calls
Date: Tue, 21 Oct 2008 23:05:40 -0400

On Tue, Oct 21, 2008 at 9:24 PM, Eric Blake <address@hidden> wrote:
> Hash: SHA1
> According to Dmitriy Kargapolov on 10/21/2008 3:35 PM:
>> Hi,
>> I tried suggested erlang.m4 patch and it works. Just one minor issue -
>> it works only when I run autoconf with "-i" option... I'm not familiar
>> with m4 stuff, but found that this is something related to "frozen"
>> files...
> Are you sure it was -i, and not something else?  Pasting an actual command
> line of what you had to use might be helpful.

Yes, that was "autoconf -i" - I tried to trace problem out. Per
autoconf code - this option results in adding " --melt" to
$autom4te_options, i.e. kind of defrosting side effect :)

>> How to deal with this?
> I'm guessing that you modified the installed copy of erlang.m4, rather
> than modifying the source file and reinstalling everything.  Yes, autoconf
> favors the frozen files (extension .m4f) that were created at the time it
> was installed, if those exist, even if they are older than the .m4 source
> files.  However, since they are just cache files, you should be able to
> safely delete them (at which point, it will use your modifed .m4 file
> instead), instead of reinstalling autoconf.

This exactly explains what I have. Thank you for help!

> - --
> Don't work too hard, make some time for fun as well!
> Eric Blake             address@hidden
> Version: GnuPG v1.4.9 (Cygwin)
> Comment: Public key at
> Comment: Using GnuPG with Mozilla -
> ErgAn22NncFazDrMqUxwElloIbAQSPXI
> =BElw

reply via email to

[Prev in Thread] Current Thread [Next in Thread]