[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Swftools-common] SwfTool Install - CentOS5.4 - "no way to define 64 bit

From: Kevin Callahan
Subject: [Swftools-common] SwfTool Install - CentOS5.4 - "no way to define 64 bit integer" problem
Date: Sun, 6 Dec 2009 17:44:50 -0600


I’ve been trying to install 0.9.0 on centos 5.4 and running into issues. Swftools 0.8.1. was installed fine and I believe I have all the required libraries: lame, lame-devel, t1lib, etc.

I’ve tried searching for those with similar problems but there are no answers:

I’ve attached both the config.log and the results of my “make”

Here’s my system:
address@hidden swftools-0.9.0]# uname -a
Linux localhost.localdomain 2.6.18-128.el5 #1 SMP Wed Jan 21 10:44:23 EST 2009 i686 i686 i386 GNU/Linux

The gist of the error is ./configure runs and then when I make, it outputs:

make[1]: Entering directory `/opt/alfresco/swftools-0.9.0/lib/pdf'
g++ -DHAVE_CONFIG_H -I/usr/include/freetype2 -I/usr/include/fontconfig -I /usr/include/lame -g ../../src/pdf2swf.c GFXOutputDev.o InfoOutputDev.o BitmapOutputDev.o FullBitmapOutputDev.o pdf.o fonts.o xpdf/GHash.o xpdf/GList.o xpdf/GString.o xpdf/gmem.o xpdf/gfile.o xpdf/FoFiTrueType.o xpdf/FoFiType1.o xpdf/FoFiType1C.o xpdf/FoFiBase.o xpdf/FoFiEncodings.o xpdf/OutputDev.o xpdf/PDFDoc.o xpdf/Error.o xpdf/Stream.o xpdf/Object.o xpdf/Decrypt.o xpdf/Array.o xpdf/XRef.o xpdf/Dict.o xpdf/Parser.o xpdf/Lexer.o xpdf/Outline.o xpdf/PDFDocEncoding.o xpdf/Catalog.o xpdf/Link.o xpdf/GlobalParams.o xpdf/JBIG2Stream.o xpdf/Page.o xpdf/JPXStream.o xpdf/JArithmeticDecoder.o xpdf/Gfx.o xpdf/GfxFont.o xpdf/CMap.o xpdf/CharCodeToUnicode.o xpdf/PSTokenizer.o xpdf/FontEncodingTables.o xpdf/BuiltinFont.o xpdf/BuiltinFontTables.o xpdf/GfxState.o xpdf/Function.o xpdf/Annot.o xpdf/NameToCharCode.o xpdf/UnicodeMap.o xpdf/SecurityHandler.o  xpdf/SplashOutputDev.o xpdf/SplashFont.o xpdf/SplashState.o xpdf/Splash.o xpdf/SplashBitmap.o xpdf/SplashClip.o xpdf/SplashPattern.o xpdf/SplashFontEngine.o xpdf/SplashFontFile.o xpdf/SplashFontFileID.o xpdf/SplashScreen.o xpdf/SplashPath.o xpdf/SplashXPath.o xpdf/SplashXPathScanner.o xpdf/SplashFTFontEngine.o xpdf/SplashFTFontFile.o xpdf/SplashFTFont.o ../libgfxswf.a ../libgfx.a ../librfxswf.a ../libbase.a -o pdf2swf -L/usr/local/lib -lmp3lame -lglut -lGLU -lGL -lungif -ljpeg -lz -lm  -lfontconfig -lfreetype
In file included from ../../src/../lib/./bitio.h:23,
                 from ../../src/../lib/rfxswf.h:37,
                 from ../../src/pdf2swf.c:41:
../../src/../lib/./types.h:36:2: error: #error "no way to define 64 bit integer"
../../src/../lib/./types.h:39:2: error: #error "don't know how to define 32 bit integer"
../../src/../lib/./types.h:42:2: error: #error "don't know how to define 16 bit integer"
../../src/../lib/./types.h:45:2: error: #error "don't know how to define 8 bit integer"
make[1]: *** [pdf2swf] Error 1
make[1]: Leaving directory `/opt/alfresco/swftools-0.9.0/lib/pdf'
make: *** [all] Error 2

When I commented out the lines from types.h I ran a make and got a host of errors, most notably along the lines of:
“devices/swf.c:1487: warning: cast to pointer from integer of different size”

Any ideas? Thank you in advance!


Attachment: config.log
Description: config.log

Attachment: make.out
Description: make.out

reply via email to

[Prev in Thread] Current Thread [Next in Thread]