[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Swftools-common] Re: Runtime errors w/ pdf2swf --flashversion=9

From: Zohair Hyder
Subject: [Swftools-common] Re: Runtime errors w/ pdf2swf --flashversion=9
Date: Tue, 9 Dec 2008 18:22:38 -0800

Using "-s disablelinks" seems to have resolved the problem. This works
for me since I don't really need links to work anyway. If this was
well-known, sorry for the spam.

On Tue, Dec 9, 2008 at 5:28 PM, Zohair Hyder <address@hidden> wrote:
> I need to use flashversion=9 for a Flex project. I don't need any
> viewer (or loader) per se. I've tried various combinations but I
> believe the following command should be sufficient:
> pdf2swf --flashversion=9 source.pdf -o dest.swf
> The resulting swf produces the following runtime errors when loaded
> (whether within Flex or separately by Flash Player):
> VerifyError: Error #1033: Cpool entry 2 is wrong type.
> ReferenceError: Error #1065: Variable MainTimeline is not defined.
> If I load it with Flash Player, after dismissing the errors, I can see
> (what looks like) a properly converted swf. Within the Flex project,
> the swf is automatically unloaded upon running into the errors though.
> For reference, I'm using:
> - Mac OS 10.5.5
> - Tried both Flash Player 9.0.124 and
> - swftools-2008-11-19-1013 (latest dev snapshot)
> Thanks for the help!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]