[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Swftools-common] swftools/swfrender installation problem under Mac

From: coder0815
Subject: Re: [Swftools-common] swftools/swfrender installation problem under Mac Leopard
Date: Tue, 23 Sep 2008 13:28:36 +0200
User-agent: Thunderbird (Macintosh/20080707)

Ok, just for info. I got it to compile.

Just went to the directory of the downloaded swftools-2008-09-18-1940 (Not the CVS checkout directory), made configure + make as described on the FAQ-page.
Then went to the src directory and made a

make swfrender

Works now.

Hope this helps someone...


coder0815 schrieb:

If nobody has a Leopard binary of swfrender, could somebody give me a binary for Ubuntu?...please!


coder0815 schrieb:

i'm trying to install the swftools with swfrender under Mac Leopard.

The swftools-2008-09-18-1940.tar.gz just works fine, but i wanted to test swfrender which is in CVS.

So, i've downloaded the CVS-version and tried:

$ LDFLAGS="-L/opt/local/lib" CPPFLAGS="-I/opt/local/include -I/opt/local/include/lame" ./configure

$ make

and i get a bunch of errormessages:

GFXOutputDev.cc:40:20: error: config.h: No such file or directory
GFXOutputDev.cc:45:19: error: gfile.h: No such file or directory
GFXOutputDev.cc:46:21: error: GString.h: No such file or directory
GFXOutputDev.cc:48:20: error: Object.h: No such file or directory
In file included from /usr/include/c++/4.0.0/backward/Stream.h:31,
                 from GFXOutputDev.cc:49:
/usr/include/c++/4.0.0/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <iostream> instead of the deprecated header <iostream.h>. To disable this warning use -Wno-deprecated.
GFXOutputDev.cc:50:19: error: Array.h: No such file or directory
InfoOutputDev.h:26:29: error: SplashOutputDev.h: No such file or directory
InfoOutputDev.h:33:25: error: SplashTypes.h: No such file or directory
InfoOutputDev.h:34:24: error: SplashPath.h: No such file or directory
InfoOutputDev.h:35:24: error: SplashFont.h: No such file or directory
InfoOutputDev.h:36:28: error: SplashFontFile.h: No such file or directory
InfoOutputDev.h:42:19: error: GHash.h: No such file or directory
InfoOutputDev.h:47: error: ISO C++ forbids declaration of ‘SplashPath’ with no type
InfoOutputDev.h:47: error: expected ‘;’ before ‘*’ token
GFXOutputDev.cc:2693: error: expected ‘,’ or ‘;’ before ‘{’ token
make[2]: *** [GFXOutputDev.o] Error 1
make[1]: *** [libpdf.a] Error 2
make: *** [all] Error 2

I've tried this:


but had no luck.

Could someone please help me to compile the swfrender under Leopard? Or does someone has a binary (for Intel)?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]