[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Swftools-common] Swfc return codes

From: Tyn
Subject: Re: [Swftools-common] Swfc return codes
Date: Tue, 04 Sep 2007 15:28:01 +0200
User-agent: Thunderbird (Windows/20070728)

After a very helpful mail exchange with Matthias (thanks again), this issue was "resolved" by splitting the huge AS block in shorter blocks like :

 (part 1)
 (part 2)

It worked like a charm, until today... Where I met another strange output code! The symptoms are the same as before: large SC file, huge AS part, no error display, a "apparently" valid SWF file on the output, and a return code of... 2. And after a short look at the source code, I wasn't able to see any exit(2) or return 2 from the main.

Hoping for another easy answer like for the previous issue :)

Thank you again.
Hi everyone,

I'm new to this mailing list but have been using Swftools everyday for the longest time.

Up to now, I assumed that swfc returned 0 when successful, and 1 when not. But today, it started to return 1 while compiling a large SC file containing a huge part of ActionScript. But the --verbose mode doesn't display anything, and everything else seems just fine.

Therefore, the output file seems okay, and the AS code is valid (it compile using Macromedia compiler).

So I wonder : what are the return codes of swfc? Is my output file really ok, or is it erroneous? I have to be sure of the validity of the file before using it in a production environment.

Thank you !

reply via email to

[Prev in Thread] Current Thread [Next in Thread]