[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] No space left/setxattr problem.

From: apatca
Subject: Re: [rdiff-backup-users] No space left/setxattr problem.
Date: Sat, 26 Mar 2016 21:03:51 +0100

That is good advice, and in the future I'll make sure to add
--exclude-special-files and any other sane options to prevent possible
problems. Sadly that didn't allow me to restore the damaged backup
directory, but I decided to take your advice and look for other useful
options in the manpage, and I found one. I ran:

sudo rdiff-backup --no-eas --check-destination-dir /backups/harvey-home/

And it worked. My backup directory seems to be fixed and I can now list
increments again. I think the problem is fixed, though I'll know for
sure when I try to back up again.

This is uncharted territory for me, but I figure I'm better off
disabling backing up of extended attributes with --no-eas to prevent
such problems in the future.

Everyone, thank you for your ideas and your support.

> Hello,
> I once have issue with disk space when backing-up special files. e.g.:
> socket or device (like /dev or /proc). Make sure to only backup real
> file. Check rdiff-backup manual to exclude those files.
> --
> Patrik Dufresne Service Logiciel inc.
> http://www.patrikdufresne.com <http://patrikdufresne.com/>/
> 514-971-6442
> 1-114 rue des Hautbois,
> St-Colomban, QC J5K 2H6

reply via email to

[Prev in Thread] Current Thread [Next in Thread]