[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] Help - rdiff-backup removing permision on target fo

From: bt101
Subject: [rdiff-backup-users] Help - rdiff-backup removing permision on target folder
Date: Sat, 24 May 2014 21:26:33 -0700

Ok solved it.. "sorta".

I ran rdiff-backup with verbosity=9.  One of the last thing it does is copy 
permissions and time stamps from the source folders to the target folders.  The 
very last folder it does is the root of your target folder.  You would think 
that rdiff-backup would only treat the target folder as a container for the 
backup as well as the rdiff-backup specific control folder.  That way 
rdiff-backup could ALWAYS get to its control folder.  Instead, it treats that 
root of the taget folder as part of the backup and changes its permissions to 
match the root of your source directory, which (if your source directory has no 
permissions) could potentially cut-off access to the rdiff-backup control 

I logged-in the the cygwin machines via ssh.
Went to the root folder (cd /).
When I did an (ls -al), the good/test system showed various permissions on the 
(.) and (..) folder.  The bad system showed none/blank permissions.  I have no 
idea why the cygwin root folder ended up with different permissions on each 

One option is to not do the backup from (/) but rather from (/cygdrive).  The 
worked OK as the cygdrive folder did not have blank permissions.  However I 
still wanted to backup from (/) since all my other backups did this.

Instead, I just changed the permissions on the (/) of cygwin.

To get to the cygwin root folder, I went through the cygdrive path (cd 
/cygdrive/c/path_to_cygwin_dir).  I then did an (ls -al) and it showed the same 
blank permissions as viewed from the (/) dir as described above.  At that 
location, I just did a chmod of the permissions to match the good/test system.  
I verified the permission changes by going back to the (/) dir and doing an (ls 

So be aware that rdiff-backup can kill its access to its own control folder.  
It should really put the backup folders and the control folder inside the root 
of the target folder at the same level and not make modifications to the 
permissions of the target folder.

|This was sent by address@hidden via Backup Central.
|Forward SPAM to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]