[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] cannot directly recover file but enclosing fold

From: Nicolas Jungers
Subject: Re: [rdiff-backup-users] cannot directly recover file but enclosing folder
Date: Sun, 16 Mar 2014 10:18:31 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.2.0

On 2014-03-15 15:08, Robert Nichols wrote:
On 03/15/2014 01:53 AM, Nicolas Jungers wrote:
Yesterday I discovered that the user cannot recover a deleted file any
more. But
the user can recover the directory two levels above and from there
extract the
desired file.

That seems quite odd to me and I wonder what can lead to that
situation? I
suspect that it can be due to the fact that the directory was deleted,
deletion recorded by riff-backup and later the directory got

I cannot reproduce that behavior. What was the exact command used in the
unsuccessful attempt? Note that specifying a time like "-r 0B" or "-r 2B"
probably won't work because those integers refer to the increments of the
total archive, not increments of the particular file. You need to run
"rdiff-backup -l /archive_dir/path/to/the/file" to get the list of
increments available for that file, and then use one of those timestamps
in the argument to "-r".

Well, I started with rdiff-web. That showed an erased file with 19 available revisions. Selecting the one I wanted (or the last or the first one) gave the error message:
        Invalid data parameter

Then I tried a rdiff-backup cmd with:
        rdiff-backup -r 2013-08-20 <path_to_the_file> <restore_path>
That silently gave nothing.

Digging in the rdiff-backup-data, I found the diff that interested me and I ran
        rdiff-backup <path_to_the_diff.gz> <restore_path>
That gave me:
        Fatal Error: Source file <path_to_the_diff.gz> does not exist

Then a
        rdiff-backup -l <path_to_file>
        Found 0 increments:
        Current mirror: Sun Mar 16 00:31:01 2014

        rdiff_backup -l <path_to_enclosing_directory>
for the same result.

But, doing a
        rdiff_backup -l <path_to_enclosing_enclosing_directory>
gave me 1269 revisions, including the one of interest.

Restoring the directory gave me the file I was looking for.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]