[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Have rdiff-backup not preserve permissions?

From: Dominic Raferd
Subject: Re: [rdiff-backup-users] Have rdiff-backup not preserve permissions?
Date: Thu, 21 Mar 2013 17:18:40 +0000
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20130307 Thunderbird/17.0.4

Which version of windows? There is a known bug in Cygwin which causes big problem under Windows 8 (but also exists under Windows 7) by which the 'group' of the cygwin user is set incorrectly.

To fix this for any future files:

- Look up the group ID of the "Users" group in /etc/group:
cat /etc/group|egrep '^Users:'|cut -f3 -d':'
- Edit your /etc/passwd file. Locate the record for your user. The 4th colon-delimited field is the "primary group" for the user, incorrectly set to a non-existent group. Change that number to the number you found above and save the file.
- Close the cygwin terminal and reopen. Create a new file. It should have group "Users" and you should be able to change its permissions as desired.

To correct existing files with wrong group settings use a recursive chgrp like this (for all files in user's home):

chgrp -R Users ~

It might help?


On 19/03/2013 22:31, Dave Potts wrote:

I've exactly the same problems as Timothy Stella.  I'm running cygwin on windows to debain linux.  The first backup works fine.  The second fails with permission issues on the directory I'm backing up to.  Does anyone have a solution?



From:     Timothy Stella
Subject:     [rdiff-backup-users] Have rdiff-backup not preserve permissions?
Date:     Fri, 1 Mar 2013 09:57:28 -0800
I'm currently having a problem with rdiff-backup backing up some data. It's running into really weird permissions issues.
I am using rdiff-backup 1.2.8 on CentOS pulling from rdiff-backup 1.2.8 on Cygwin (winxp) like so:
backup@ centos$rdiff-backup -v6 address@hidden::/cygdrive/c/files/ /mnt/backups/winserver/files/
I have it backing up a directory -- the first time the backup runs, everything is fine. The second time, however, I get permission issues with the local copy (the directory I am backing up to).
I tried to remedy this by adding a chmod -R u+rwx at the end of my script, but it doesn't seem to help.
I also tried to set the directory to 777 just to see if it'd work, and it still fails. However, running the backup as root does work.
It is also worth noting that other directories (separate rdiff-backup runs) for that same server are working without issue.
I tried to look up if I can have rdiff-backup just ignore the remote (in this case, winserver) permissions but it doesn't seem possible. Is there any way for me to get around this other than running that one directory as root?

rdiff-backup-users mailing list at address@hidden
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki

TimeDicer: Free File Recovery from Whenever

reply via email to

[Prev in Thread] Current Thread [Next in Thread]