[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] moving backup dir to external server produce er

From: me
Subject: Re: [rdiff-backup-users] moving backup dir to external server produce errors
Date: Tue, 04 Dec 2012 09:59:00 +1100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Thunderbird/17.0

Le 04/12/2012 07:15, address@hidden a écrit :
Sorry for the mess with archives ...

Here is the new thread with answer.

Le 04/12/2012 02:15, chuck odonnell a écrit :
On Mon, Dec 03, 2012 at 09:34:23AM +1100, address@hidden wrote:
Hi all,
I had a rdiff-backup (1.2.8) that was setup to backup files locally
(on the same server).
I ran out of space on this server so I have copied via scp the
backup directory to another server like this :
scp -r /home/backup/web address@hidden:/home/server/backup/
Then I have modified the rdiff-backup script to send to the new location :
nice -n 19 rdiff-backup /var/www
address@hidden::/home/server/backup/web && nice -n 19 rdiff-backup
--remove-older-than 30B --force
But now I getting lot of errors from email files and temp session
files in this directory like this :
web13/web/files/tmp/sess_fdfa4a5f841d931ff590a273f9022286 File
changed from regular file before signature
I've tried to use the --force option but it still produce the same errors.
A lot of rdiff's efficiences are based on the underlying filesystem,
so you have to use a copy strategy that precisely duplicates the
respository at a filesystem level. scp may be a little too naive for
this purpose, or at least, the default settings are. In any case,
rsync -avz has always worked for me in the past when moving


Thanks Chuck, I'll give rsync a try.

rdiff-backup-users mailing list at address@hidden
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki

Thanks again Chuck,
It did the trick ;-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]