[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] moving backup dir to external server produce er

From: chuck odonnell
Subject: Re: [rdiff-backup-users] moving backup dir to external server produce errors
Date: Mon, 3 Dec 2012 10:13:22 -0500

On Mon, Dec 03, 2012 at 09:34:23AM +1100, address@hidden wrote:
> Hi all,
> I had a rdiff-backup (1.2.8) that was setup to backup files locally
> (on the same server).
> I ran out of space on this server so I have copied via scp the
> backup directory to another server like this :
> scp -r /home/backup/web address@hidden:/home/server/backup/
> Then I have modified the rdiff-backup script to send to the new location :
> #!/bin/sh
> nice -n 19 rdiff-backup /var/www
> address@hidden::/home/server/backup/web && nice -n 19 rdiff-backup
> --remove-older-than 30B --force
> address@hidden::/home/server/backup/web
> But now I getting lot of errors from email files and temp session
> files in this directory like this :
> UpdateError
> web13/web/files/tmp/sess_fdfa4a5f841d931ff590a273f9022286 File
> changed from regular file before signature
> I've tried to use the --force option but it still produce the same errors.

A lot of rdiff's efficiences are based on the underlying filesystem,
so you have to use a copy strategy that precisely duplicates the
respository at a filesystem level. scp may be a little too naive for
this purpose, or at least, the default settings are. In any case,
rsync -avz has always worked for me in the past when moving



reply via email to

[Prev in Thread] Current Thread [Next in Thread]