[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Weird behavior of rdiff-backup : founding diffs

From: Nicolas Jungers
Subject: Re: [rdiff-backup-users] Weird behavior of rdiff-backup : founding diffs while there isn't
Date: Sat, 17 Nov 2012 11:55:38 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20121028 Thunderbird/16.0.2

Hi Matthieu,

I had only a quick read of your mail, but for me it smells hardware problem. Have you cross-checked your cables, interfaces and storage medium?


On 2012-11-16 11:21, address@hidden wrote:
Hi all,

I recently decided to choose rdiff-backup as backup tool on 2 Linux

One is running it perfectly.

But the other one has a strange behavior when running rdiff-backup.
Actually, it find differences in a lot of files while there isn't any.
This leads to rdiff-backup overwriting a lot of files for nothing and
taking a long time.

Let me take an example to clarify things.

Consider I already have 2 backups done on a daily basis (let me call them
A and B chronologically -- thus B is the current mirror).

I run 'rdiff-backup --compare' just before backing up : it returns "no

I run the back up and here rdiff-backup finds thousand of files that have
changed (viewed from session statistics) !!!
This backup is called C and is the new mirror.

When I look at the file statistics, a lot of files are marked as changed.
The first weird thing here is that IncrementSize is not null while
SourceSize and MirrorSize are identical (IncrementSize is always a small
number - <128 -).

For example : home/USER/.kde/share/config/katerc 1 67 67 66

Second weird thing is that absolutely no diff between C and B is stored
nor in the data itself, nor in the metadata

Now looking at the source files : their access times (and only these ones)
have been updated at the time of the backup (thus rdiff-backup does
something that changes this).
Looking at the destination files : their access and change times have been
updated also but not the modify time.

Last very weird thing : if I run a rdiff-backup --compare-at-time 1B (thus
comparing current files with old B backup), it returns "no changes" ...

At now my thinking is that rdiff-backup views a difference while there
isn't when running in the backing up context but clearly see that there
isn't in the comparing context.

I also runned a rdiff-backup --compare every 5 minutes with a cronjob and
it always return "no changes" except at the time where the backup started.
Thus it seems that riff-backup is itself fooling itself... But not sure
because if I run things manually (instead of cronjob), everything works

I don't know why I'm having this behavior at now but for sure I'd like to
prevent it to appear. ;-)

Did anyone already have this behavior ? And eventually found the cause and
fix that ?

As information, below the characteristics of the system (and between
parenthesis the ones of the other machine when everything works well as

  - rdiff-backup version : 1.2.8 (1.2.8)
  - OS : Kubuntu 11.04 (Debian Wheezy)
  - kernel : 2.6.38 (3.2.0)
  - launching way : cronjob (cronjob)
  - source FS : ext4 (ext3)
  - destination FS : ext4 (ext4)

So basically only noticeable difference is a quite old kernel on the
screwing up machine.

I will increase verbosity of rdiff-backup and keep you updated.

In between, thanks in advance for any help and support. Feel free to ask
if missing information can help.

Best regards,

rdiff-backup-users mailing list at address@hidden
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki

reply via email to

[Prev in Thread] Current Thread [Next in Thread]