[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Please help getting my backups running.

From: Dominic Raferd
Subject: Re: [rdiff-backup-users] Please help getting my backups running.
Date: Fri, 02 Nov 2012 16:48:05 +0000
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20121026 Thunderbird/16.0.2

Well Gary I'm glad you succeeded in the end, and pleased to be of service.

Yes normally the build location is /usr/src (absolute location) but you seemed to be using ./usr/src that is why I suggested you stick with that. If it has worked for you with /usr/src then that's better IMHO.

I have now uploaded my rdiff-backup installer program rdiff-backup-install.sh to the web - help and download page at http://www.timedicer.co.uk/programs/help/rdiff-backup-install.sh. I've tweaked and renumbered it v0.3. If you use it again please use the latest version from there just so that I can check it is bug-free.

Now that you have rdiff-backup working you might want to install rdiffweb which provides a web interface for retrieving files from the rdiff-backup server; install program is at http://www.timedicer.co.uk/programs/help/rdiffweb-install.sh.

Regards, Dominic
TimeDicer: Free File Recovery from Whenever

On 02/11/2012 13:50, Gary Rickert wrote:
Well Dominic, I sure hope you have had as much fun as I have:)

All kidding aside, it looks like this script did it. I installed on my backup system, ran and got the version mis-match message, as expected. Ran rdiff-backup-install.sh on my other system, ran and all again looks OK. Thank you, thank you.

So, what was the challenge?

I will be doing a bunch more testing/bench-marking again in a few days, but I have some catching up to do after spending most of the last week emersed in this. I haven't looked in detail at the following install output, or tried to figure out the install script, but I believe the destination address in the install command line (/usr/src) should be absolute, not relative. y/n?

My hope is that you don't hear from me again, but hope I haven't worn out my welcome if I do have more issues. It is not often that I see this level of responsiveness, even from paid vendors.

Thanks again

root ~/install#./rdiff-backup-install.sh 1.2.8 /usr/src

rdiff-backup-install.sh v0.2 [02 Nov 12] by Dominic (-h for help)

Searching for librsync.so*: /usr/lib
Searching for Python.h: /usr/include/python2.4/Python.h
Download rdiff-backup-1.2.8.tar.gz [y/-]: y
Untar the rdiff-backup-1.2.8.tar.gz [y/-]: Build the downloaded program [y/-]: y
running build


On Fri, Nov 2, 2012 at 3:30 AM, Dominic Raferd <address@hidden> wrote:
Here is a further-improved version of my script, and hopefully it can now use yum to install any missing dependencies. Notice that its name has changed to rdiff-backup-install.sh (i.e. with '.sh' added at the end). Try this (v0.2) instead of the one I sent a couple of hours ago.


On 02/11/2012 00:50, Gary Rickert wrote:
I hope "without any warranties" doesn't mean without assistance:}
When I run the script I get:

root ~/install/rdiff-backup-1.2.8 #  installrdiff -pnq 1.2.8 /opt
Unable to locate librsync.a. Please install librsync-dev and try again.

root ~/install/rdiff-backup-1.2.8 #  installrdiff -pnq rdiff-backup-1.2.8 /opt
Unable to locate librsync.a. Please install librsync-dev and try again.

The first thing I noticed was the package name installed:
Package librsync-devel-0.9.7-13.el5.x86_64 already installed and latest version
Package librsync-devel-0.9.7-13.el5.i386 already installed and latest version
Name       : librsync
Arch       : x86_64
Version    : 0.9.7
Release    : 13.el5

Hope this search may help:

Can't think of anything else that may help you, but I pray you can help me.

On Thu, Nov 1, 2012 at 5:14 PM, Dominic Raferd <address@hidden> wrote:
Oh dear. It looks like some sort of installation issue, probably some confusion of directories.

I attach a script I wrote a little while ago to auto-install rdiff-backup 1.2.8. I haven't used it for a while and it has not I think been tested under Centos but it should work. Unzip the attachment and then run the file with superuser permissions (i.e. with sudo if you are not already root). Use -h option to see the help first. Don't use the -p option (the patch it suggests doesn't really help.)

I'm afraid it comes without any warranties of course!



On 01/11/12 22:46, Gary Rickert wrote:
Well Dominic. Hope you are the patient type. I just broke it installing 1.2.8.
Name  : python Arch : x86_64 Version  : 2.en Release  : 46.el5_8.2

Name  : python-devel Arch  : i386 Version : 2.4.3 Release  : 46.el5_8.2
Name  : librsync Arch : i386 Version : 0.9.7 Release : 13.el5
Name  : librsync-devel Arch : x86_64 Version : 0.9.7 Release : 13.el5
root rdiff-backup-1.2.8 # python setup.py install --prefix=/usr/local

When I try to run it, I get:

Traceback (most recent call last):
  File "/usr/local/bin/rdiff-backup", line 20, in ?
    import rdiff_backup.Main
ImportError: No module named rdiff_backup.Main

Things were finally going so well. What have I done to myself, and hopefully how do I fix it.

On Wed, Oct 31, 2012 at 9:49 PM, Gary Rickert <address@hidden> wrote:
Thanks again Dominic,
What distro are you using? Centos 5.6 3.0.18-x86_64-linode24
I also don't understand the path to usr/bin either, but it will be needed in the cron script version anyway.
I always appreciate having a good understanding of what I do, which is often just answered, seldom explained in the search results. I usually can figure out scripts, but sometimes there are real challenges.
Thanks for all the help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]