[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Winsdows 7/Vista ACLs not restored correctly?

From: Dominic Raferd
Subject: Re: [rdiff-backup-users] Winsdows 7/Vista ACLs not restored correctly?
Date: Sat, 08 Sep 2012 09:26:59 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/20120827 Thunderbird/15.0

Leland, have you tried doing the backup from your Windows machine to a Linux host and then restoring from there?

Or, if that is not possible, using the linux version of rdiff-backup on your Windows machine through cygwin?


On 07/09/12 22:56, Leland Best wrote:
Hello All,

I've tried Googling this problem as well as searching the mailing list
archives with no luck.  Also there was a Wiki about Windows -> Linux
backups but that seems to have been down for quite a while now.  So, my
apologies if this has been answered somewhere and I just haven't found
it.  Anyway, ...

The short version is: When I back up then restore using the rdiff-backup
win32 binaries from http://www.nongnu.org/rdiff-backup/ the
permissions/ACLs are not restored correctly.  I've tried many different
combinations of things but even in the simplest cases (i.e. source,
backup, and restore directories all on c:\ someplace) the restored
permissions/ACLs are incorrect.  I need to know if this is a known issue
or whether I'm missing something.

Here are some more details.  On both Windows 7 64-bit and Windows Vista
32-bit I've done the following:

1) Download and unzip rdiff-backup-1.2.8-win32.zip (I've also tried

2) Copied the resulting rdiff-backup.exe file to C:\Program Files
\Savannah (which I created manually) and added this directory to the end
of the system-wide PATH environment variable.

3) Reboot (just to be sure the new PATH is picked up by everything).

4) Log in as, say, my normal (administrative) user which we'll call

5) Click 'Start', enter 'cmd' in the search box, right-click 'cmd.exe'
and select "Run as administrator".

6) mkdir C:\Backup

7) rdiff-backup -v 5 c:/Users/Leland
c:/Backup/Leland>c:/Backup/Leland_backup.log 2>&1

(all as one command obviously) where 'Leland' is another administrative
user I created just for testing.  After a little bit this completes
without significant errors.

8) rdiff-backup -v 5 -r now c:/Backup/Leland
c:/Users/Leland.restored>c:/Backup/Leland_restore.log 2>&1

This also appears to complete without errors.  However, when I compare
the Properties -> Security (in Windows Explorer or whatever) for C:
\Users\Leland and C:\Users\Leland.restored they are quite different.
For example, 'Leland' does not inherit from C:\Users but
'Leland.restored' does.  'Leland' only shows permissions for users
'SYSTEM', 'Leland', and 'Administrators' while 'Leland.restored' also
has permissions for 'EVERYONE', and 'Users'.  The specifics of the
permissions for each user differ too.

So, am I doing something wrong?  If so, what?  If not, then how on earth
are other folks using rdiff-backup to back up Windows machines?  Any
help, pointers, etc. would be greatly appreciated.  If posting log files
or additional info will help just let me know.

BTW (and slightly off topic) I've used rdiff-backup under Debian
GNU/Linux for years and it has worked well.  I've done "bare metal"
restores given a Debian Live CD with rdiff-backup installed.  I've even
used ntfsclone to image an entire Windows partition and put _that_ in
rdiff-backup.  It all works like a champ!  Unfortunately, none of these
are acceptable for my current application. :(

Thanks in advance.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]