[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] ImportError: No module named rdiff_backup.Main

From: Tamashii
Subject: Re: [rdiff-backup-users] ImportError: No module named rdiff_backup.Main
Date: Fri, 29 Jul 2011 17:31:35 +0200
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110624 Thunderbird/5.0

I've finally managed to get it to run - what I did was upgrading python to 2.6.7 ... (2.6.6 is standard though)

Thanks for your help :-)

Am 29.07.2011 13:03, schrieb address@hidden:
When you log in your home directory should be /root or some such.

Also, make sure what version of  python you have, it should be 2.6 for
Debian Squeeze.

Otherwise, I am out of ideas.

Tamashii<address@hidden>  wrote:

I didn't cc this message to the group.

What do you mean with "from my regular home directory?"

Am 29.07.2011 11:08, schrieb address@hidden:
Also, what if you do this from your regular home directory -- any

Tamashii<address@hidden>   wrote:

Reinstallation of the package with dpkg did not yield any favorable
results. I've also tried to remove it all and install it again with
This gave the same result:

address@hidden:/usr/lib/pymodules/python2.6# apt-get install rdiff-backup
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 24 not upgraded.
Need to get 0 B/202 kB of archives.
After this operation, 823 kB of additional disk space will be used.
Selecting previously deselected package rdiff-backup.
(Reading database ... 30265 files and directories currently installed.)
Unpacking rdiff-backup (from .../rdiff-backup_1.2.8-6_amd64.deb) ...
Setting up rdiff-backup (1.2.8-6) ...

address@hidden:/usr/lib/pymodules/python2.6# rdiff-backup -V
Traceback (most recent call last):
    File "/usr/bin/rdiff-backup", line 20, in<module>
      import rdiff_backup.Main
ImportError: No module named rdiff_backup.Main

I can try to purge it again and re-install it from sources, but if
possible I'd like to have it in packages for updates.

Thanks again,

Am 29.07.2011 06:57, schrieb address@hidden:
I would try to reinstall, also do a dpkg -L rdiff-backup and make sure
all the files are where they should be.  I am using Debina Squeeze on a
box with rdiff-backup with no problems.

Hope this helps.

Tamashii<address@hidden>    wrote:

Hello Everyone!

I've been looking at guides and fix-suggestions for this error for
several hours - did not help - so I'll try my luck here.
I've never coded anything in python - I'm just trying to run the
program. (So I have a hard time finding the problem.)

The Problem:
address@hidden:/usr/lib/python2.6/dist-packages# rdiff-backup -V
Traceback (most recent call last):
     File "/usr/bin/rdiff-backup", line 20, in<module>
       import rdiff_backup.Main
ImportError: No module named rdiff_backup.Main

I'm running Debian 6, installed the package via. "apt-get install

These are my paths:

Python 2.6.6 (r266:84292, Dec 26 2010, 22:31:48)
[GCC 4.4.5] on linux2
Type "help", "copyright", "credits" or "license" for more information.
import sys
['', '/usr/lib/pymodules/python2.6', '/usr/lib/python2.6',
'/usr/lib/python2.6/plat-linux2', '/usr/lib/python2.6/lib-tk',
'/usr/lib/python2.6/lib-old', '/usr/lib/python2.6/lib-dynload',
I've already copied the folder to any imagineable location - no luck:

address@hidden:/usr/lib/python2.6/dist-packages# locate rdiff_backup | grep

address@hidden:/usr/lib/python2.6/dist-packages# locate rdiff_backup | grep 

Those directories above should all be in the python path.

address@hidden:/usr/lib/python2.6/dist-packages# locate rdiff-backup

Any ideas what I can try to solve this?

Thanks in advance,

rdiff-backup-users mailing list at address@hidden
Wiki URL: http://rdiff-backup.solutionsfirst.com.au/index.php/RdiffBackupWiki

reply via email to

[Prev in Thread] Current Thread [Next in Thread]