[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] Question about file removal

From: Jeff Squyres
Subject: [rdiff-backup-users] Question about file removal
Date: Fri, 23 Jul 2010 17:44:34 -0400

Many thanks for rdiff-backup -- I use it every week to backup my Mac laptop.  Woo hoo!

I have a question about removing files.  On my laptop, I used to have a 17GB file (a disk image).  I had it rdiff-backedup to my remote backup server and everything was fine.  However, I now no longer need that 17GB file, so I removed it on my laptop.  Now I'm running my weekly rdiff-backup and it seems to be "stuck" on that 17GB file (I run with --verbosity 5 --terminal-verbosity 5, so I can see where the backup is).  Here's the last message I see:

Incrementing mirror file /path/on/remote/server/of/17GB/file

It's been "stuck" there for about 30 minutes.  Is this normal?  I'm guessing it's doing *something*, but I'm not versed in backup / rsync protocols why it wouldn't be a simply "this file no longer exists at the source, delete it at the destination" control message.

FWIW: I run rdiff-backup this way:

    rdiff-backup \
        --force \
--exclude-device-files \
--exclude-fifos \
--exclude-sockets \
--exclude '**/.Spotlight-V100**' \
        ...a whole bunch of other excludes... \
--exclude '**/.emacs.d/auto-save-list' \
--print-statistics \
--remote-schema 'ssh -C -c blowfish my_backup_server_name rdiff-backup --server' \
--verbosity $verb \
--terminal-verbosity $term_verb \

Thanks for any insight you can provide.

{+} Jeff Squyres

reply via email to

[Prev in Thread] Current Thread [Next in Thread]