[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Exclude-sockets not working (Mac OS X)

From: Andrew Ferguson
Subject: Re: [rdiff-backup-users] Exclude-sockets not working (Mac OS X)
Date: Sun, 10 Jun 2007 11:31:00 -0400
User-agent: Thunderbird (Macintosh/20070326)

Ilari Scheinin wrote:
>>> I am running rdiff-backup with the --exclude-sockets option, but I am
>>> still getting this kind of error for every socket:
>>> ListError private/var/launchd/0/sock [Errno 1] Operation not
>>> permitted: '/private/var/launchd/0/sock'
>> Good catch! If the user had extended attributes support enabled (as  
>> you
>> did), rdiff-backup tried to read/set the extended attributes on the
>> socket. However, sockets don't have extended attributes on Mac OS X or
>> Linux and this attempt generates an error. I have patched this in CVS
>> and the fix will be in the next release of rdiff-backup.
> I believe that the same thing is still happening with fifos. I have -- 
> exclude-fifos, but still get:

This is now fixed in CVS and will be in version 1.1.11.


Andrew Ferguson - address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]