[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[qvm86-devel] Unable to install XP guest on XP host with qvm86

From: jeebs
Subject: [qvm86-devel] Unable to install XP guest on XP host with qvm86
Date: Tue, 26 Apr 2005 17:53:46 -0500

I just saw the qvm86 version of the Windows qemu on FreeOSZoo, so I downloaded 
and tried it.

(It'd be nice if there was some way to actually verify that the module was 
running.  Since at this point qemu isn't faster with it than without it, and 
qemu runs even if it doesn't have qvm86 running, it'd be nice if there was some 
confirmation, just to make sure the user manually installed it right.)

The docs should mention you can do "net stop qvm86" to remove it.


I tried to install XP host with the WinXP guest.  Just like I've been doing 
with regular qemu.

I used the same basic qemu setup.

This time qemu fails much sooner than normal.  (As I think most people already 
know, the Windows version of Qemu isn't nearly as robust as the Linux version.)

Normally, XP fails with me after the installation, at the point where it wants 
to resize the screen.

This time, it was after the first reboot (after it had copied the files) and 
was doing the initial loading of the catalogs to begin the actual installation.

The only notice that it said was simply that the catalog was incomplete and 
that it was a fatal error.

I tried this a second time and it rebooted and just froze at the "39 minutes 
remaining" part, where it actually starts the installation.

So this appears to be a more subtle error that's causing XP to misbehave, 
rather than a failure that causes XP to fail with a useful error message.

For the record, I did try XP with the non-qvm86 version and it does get past 
that point.

I haven't tried Win98 under qvm86 yet.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]