qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] [PATCH v3 00/13] pc-dimm: next bunch of cleanups


From: David Hildenbrand
Subject: Re: [Qemu-ppc] [PATCH v3 00/13] pc-dimm: next bunch of cleanups
Date: Mon, 18 Jun 2018 14:32:33 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.8.0

On 15.06.2018 16:04, David Hildenbrand wrote:
> This is another set of cleanups as the result from
>     [PATCH v4 00/14] MemoryDevice: use multi stage hotplug handlers
> And is based on
>     [PATCH v1 0/2] memory: fix alignment checks/asserts
> 
> These cleanup are the last step before
> - 1. moving pc-dimm address and slot assignment into pc_dimm_pre_plug
> - 2. factoring out pre_plug, plug and unplug logic of memory devices
>      completely
> 
> v2 -> v3:
> - "nvdimm: no need to overwrite get_vmstate_memory_region()"
> -- reshuffeld to avoid breaking compilation in between patches
> - "nvdimm: convert "label-size" into a static property"
> -- replace by "nvdimm: convert nvdimm_mr into a pointer"
> -- and "nvdimm: allow setting the label-size to 0"
> 
> v1 -> v2:
> - deferring "pc-dimm: assign and verify the "slot" property during pre_plug"
> - deferring "pc-dimm: introduce and use pc_dimm_memory_pre_plug()"
> - dropped "pc-dimm: get_memory_region() will never return a NULL pointer"
> - dropped "pc-dimm: don't allow to access "size" before the device was 
> realized"
> - dropped "spapr: move memory hotplug size check into plug code"
> - dropped "pc-dimm: get_memory_region() can never fail"
> -- replaces by "pc-dimm: get_memory_region() will not fail after realize"
> - added "pc: rename pc_dimm_(plug|unplug|...)* into ..."
> - added "pc-dimm: rename pc_dimm_memory_* to pc_dimm_*"
> - added "pc-dimm: remove pc_dimm_get_free_slot() from header"
> - added "pc-dimm: merge get_(vmstate_)memory_region()"
> - added "nvdimm: convert "unarmed" into a static property"
> - added "nvdimm: convert "label-size" into a static property"
> - added "nvdimm: make get_memory_region() perform checks and initialization"
> 
> David Hildenbrand (13):
>   pc-dimm: remove leftover "struct pc_dimms_capacity"
>   pc: rename pc_dimm_(plug|unplug|...)* into
>     pc_memory_(plug|unplug|...)*
>   pc-dimm: rename pc_dimm_memory_* to pc_dimm_*
>   pc-dimm: remove pc_dimm_get_free_slot() from header
>   pc: factor out pc specific dimm checks into pc_memory_pre_plug()
>   nvdimm: no need to overwrite get_vmstate_memory_region()
>   hostmem: drop error variable from host_memory_backend_get_memory()
>   pc-dimm: merge get_(vmstate_)memory_region()
>   nvdimm: convert "unarmed" into a static property
>   nvdimm: convert nvdimm_mr into a pointer
>   nvdimm: allow setting the label-size to 0
>   nvdimm: make get_memory_region() perform checks and initialization
>   pc-dimm: get_memory_region() will not fail after realize
> 
>  backends/hostmem.c       |  3 +-
>  hw/i386/pc.c             | 73 +++++++++++++++---------------
>  hw/mem/nvdimm.c          | 95 +++++++++++++++++++++-------------------
>  hw/mem/pc-dimm.c         | 35 +++++----------
>  hw/misc/ivshmem.c        |  3 +-
>  hw/ppc/spapr.c           | 18 +++-----
>  include/hw/mem/nvdimm.h  |  2 +-
>  include/hw/mem/pc-dimm.h | 17 +++----
>  include/sysemu/hostmem.h |  3 +-
>  numa.c                   |  3 +-
>  10 files changed, 119 insertions(+), 133 deletions(-)
> 

If there are no more comments I'll send a v4 without patch #11.

-- 

Thanks,

David / dhildenb



reply via email to

[Prev in Thread] Current Thread [Next in Thread]