qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-ppc] [Qemu-devel] [PULL 00/49] ppc-for-2.13 queue 20180427


From: no-reply
Subject: Re: [Qemu-ppc] [Qemu-devel] [PULL 00/49] ppc-for-2.13 queue 20180427
Date: Fri, 27 Apr 2018 03:13:30 -0700 (PDT)

Hi,

This series seems to have some coding style problems. See output below for
more information:

Type: series
Message-id: address@hidden
Subject: [Qemu-devel] [PULL 00/49] ppc-for-2.13 queue 20180427

=== TEST SCRIPT BEGIN ===
#!/bin/bash

BASE=base
n=1
total=$(git log --oneline $BASE.. | wc -l)
failed=0

git config --local diff.renamelimit 0
git config --local diff.renames True
git config --local diff.algorithm histogram

commits="$(git log --format=%H --reverse $BASE..)"
for c in $commits; do
    echo "Checking PATCH $n/$total: $(git log -n 1 --format=%s $c)..."
    if ! git show $c --format=email | ./scripts/checkpatch.pl --mailback -; then
        failed=1
        echo
    fi
    n=$((n+1))
done

exit $failed
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
From https://github.com/patchew-project/qemu
 * [new tag]               patchew/address@hidden -> patchew/address@hidden
Switched to a new branch 'test'
626125dd6a Clear mem_path if we fall back to anonymous RAM allocation
1cb34b9657 spapr: Set compatibility mode before the rest of spapr_cpu_reset()
1a58957f3b target/ppc: Don't bother with MSR_EP in cpu_ppc_set_papr()
d6d2f6f166 spapr: Support ibm, dynamic-memory-v2 property
e3cc82abbc ppc: e500: switch E500 based machines to full machine definition
ae53594c96 spapr: Add ibm, max-associativity-domains property
afa9b64a12 target/ppc: Fold slb_nr into PPCHash64Options
29159ef8e0 target/ppc: Get rid of POWERPC_MMU_VER() macros
04a45a3cb0 target/ppc: Remove unnecessary POWERPC_MMU_V3 flag from mmu_model
98ad6b634b target/ppc: Fold ci_large_pages flag into PPCHash64Options
177121bf2a target/ppc: Move 1T segment and AMR options to PPCHash64Options
c5e9ce0454 target/ppc: Make hash64_opts field mandatory for 64-bit hash MMUs
1a1b68e40d target/ppc: Split page size information into a separate allocation
71bdec3362 target/ppc: Move page size setup to helper function
d0f975aadc target/ppc: Remove fallback 64k pagesize information
0b222ce598 target/ppc: Avoid taking "env" parameter to mmu-hash64 functions
b264b4e4ba target/ppc: Pass cpu instead of env to ppc_create_page_sizes_prop()
40fca579a0 target/ppc: Simplify cpu valid check in ppc_cpu_realize
97c3a208a6 target/ppc: Standardize instance_init and realize function names
e016914097 spapr: drop useless dynamic sysbus device sanity check
bc145fe8b7 Revert "spapr: Don't allow memory hotplug to memory less nodes"
3a6337c247 spapr: drop useless sanity check in spapr_irq_alloc*()
966de6a65e Add host_memory_backend_pagesize() helper
826920ec44 Make qemu_mempath_getpagesize() accept NULL
d515ad4b89 spapr: Introduce pseries-2.13 machine type
e708833f76 target/ppc: Fix reserved bit mask of dstst instruction
798b69e16c ppc: Fix size of ppc64 xer register
c60fb4018a uninorth: rename UNINState to UNINHostState
c4782da8e3 uninorth: move PCI IO (ISA) memory region into the uninorth device
64ebeb460f uninorth: use object link to pass OpenPIC object to uninorth
72dd5354b3 uninorth: remove obsolete pci_pmac_u3_init() function
118bd490d6 uninorth: remove obsolete pci_pmac_init() function
c784d08f0e uninorth: enable internal PCI host bridge
ff57ec3e13 uninorth: fix PCI and AGP bus mixup
6c94d593a9 uninorth: move PCI host bridge bus initialisation into device realize
f9bf749e28 uninorth: introduce temporary pic_irqs device property
69b8c6a2dc uninorth: move PCI mmio memory region initialisation into init 
function
3a1e230e19 mac_oldworld: move wiring of macio IRQs to macio_oldworld_realize()
1a00fb6cf0 mac_oldworld: remove pics IRQ array and wire up macio to heathrow 
directly
89750552a5 grackle: move PCI IO (ISA) memory region into the grackle device
39f1e52433 grackle: remove deprecated pci_grackle_init() function
875d60b543 grackle: general tidy-up and QOMify
0e29ac89fc heathrow: remove obsolete heathow_init() function
986f46a881 uninorth: alter pci_pmac_init() and pci_pmac_u3_init() to return 
uninorth device
a55c02b0f2 uninorth: move uninorth definitions into uninorth.h
100273f6a8 uninorth: remove stray PCIBus realize from mac_newworld.c
d8ae7f8b1d uninorth: QOMify PCI and AGP host bridges
37c17ba02d uninorth: remove second set of uninorth token registers
8afd2d170f uninorth: trivial style fixups

=== OUTPUT BEGIN ===
Checking PATCH 1/49: uninorth: trivial style fixups...
Checking PATCH 2/49: uninorth: remove second set of uninorth token registers...
Checking PATCH 3/49: uninorth: QOMify PCI and AGP host bridges...
Checking PATCH 4/49: uninorth: remove stray PCIBus realize from 
mac_newworld.c...
Checking PATCH 5/49: uninorth: move uninorth definitions into uninorth.h...
Checking PATCH 6/49: uninorth: alter pci_pmac_init() and pci_pmac_u3_init() to 
return uninorth device...
Checking PATCH 7/49: heathrow: remove obsolete heathow_init() function...
Checking PATCH 8/49: grackle: general tidy-up and QOMify...
Checking PATCH 9/49: grackle: remove deprecated pci_grackle_init() function...
Checking PATCH 10/49: grackle: move PCI IO (ISA) memory region into the grackle 
device...
Checking PATCH 11/49: mac_oldworld: remove pics IRQ array and wire up macio to 
heathrow directly...
Checking PATCH 12/49: mac_oldworld: move wiring of macio IRQs to 
macio_oldworld_realize()...
Checking PATCH 13/49: uninorth: move PCI mmio memory region initialisation into 
init function...
Checking PATCH 14/49: uninorth: introduce temporary pic_irqs device property...
Checking PATCH 15/49: uninorth: move PCI host bridge bus initialisation into 
device realize...
ERROR: if this code is redundant consider removing it
#46: FILE: hw/pci-host/uninorth.c:127:
+#if 0

total: 1 errors, 0 warnings, 221 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 16/49: uninorth: fix PCI and AGP bus mixup...
Checking PATCH 17/49: uninorth: enable internal PCI host bridge...
Checking PATCH 18/49: uninorth: remove obsolete pci_pmac_init() function...
Checking PATCH 19/49: uninorth: remove obsolete pci_pmac_u3_init() function...
Checking PATCH 20/49: uninorth: use object link to pass OpenPIC object to 
uninorth...
Checking PATCH 21/49: uninorth: move PCI IO (ISA) memory region into the 
uninorth device...
Checking PATCH 22/49: uninorth: rename UNINState to UNINHostState...
Checking PATCH 23/49: ppc: Fix size of ppc64 xer register...
ERROR: spaces required around that '+' (ctx:VxV)
#40: FILE: target/ppc/gdbstub.c:43:
+    case 69+32: /* xer */
            ^

total: 1 errors, 0 warnings, 59 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.

Checking PATCH 24/49: target/ppc: Fix reserved bit mask of dstst instruction...
Checking PATCH 25/49: spapr: Introduce pseries-2.13 machine type...
Checking PATCH 26/49: Make qemu_mempath_getpagesize() accept NULL...
Checking PATCH 27/49: Add host_memory_backend_pagesize() helper...
WARNING: architecture specific defines should be avoided
#35: FILE: backends/hostmem.c:266:
+#ifdef __linux__

total: 0 errors, 1 warnings, 59 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.
Checking PATCH 28/49: spapr: drop useless sanity check in spapr_irq_alloc*()...
Checking PATCH 29/49: Revert "spapr: Don't allow memory hotplug to memory less 
nodes"...
Checking PATCH 30/49: spapr: drop useless dynamic sysbus device sanity check...
Checking PATCH 31/49: target/ppc: Standardize instance_init and realize 
function names...
Checking PATCH 32/49: target/ppc: Simplify cpu valid check in ppc_cpu_realize...
Checking PATCH 33/49: target/ppc: Pass cpu instead of env to 
ppc_create_page_sizes_prop()...
Checking PATCH 34/49: target/ppc: Avoid taking "env" parameter to mmu-hash64 
functions...
Checking PATCH 35/49: target/ppc: Remove fallback 64k pagesize information...
Checking PATCH 36/49: target/ppc: Move page size setup to helper function...
Checking PATCH 37/49: target/ppc: Split page size information into a separate 
allocation...
Checking PATCH 38/49: target/ppc: Make hash64_opts field mandatory for 64-bit 
hash MMUs...
Checking PATCH 39/49: target/ppc: Move 1T segment and AMR options to 
PPCHash64Options...
Checking PATCH 40/49: target/ppc: Fold ci_large_pages flag into 
PPCHash64Options...
Checking PATCH 41/49: target/ppc: Remove unnecessary POWERPC_MMU_V3 flag from 
mmu_model...
Checking PATCH 42/49: target/ppc: Get rid of POWERPC_MMU_VER() macros...
Checking PATCH 43/49: target/ppc: Fold slb_nr into PPCHash64Options...
WARNING: line over 80 characters
#28: FILE: hw/ppc/pnv.c:183:
+    _FDT((fdt_setprop_cell(fdt, offset, "ibm,slb-size", 
cpu->hash64_opts->slb_size)));

WARNING: line over 80 characters
#42: FILE: hw/ppc/spapr.c:550:
+    _FDT((fdt_setprop_cell(fdt, offset, "slb-size", 
cpu->hash64_opts->slb_size)));

WARNING: line over 80 characters
#43: FILE: hw/ppc/spapr.c:551:
+    _FDT((fdt_setprop_cell(fdt, offset, "ibm,slb-size", 
cpu->hash64_opts->slb_size)));

total: 0 errors, 3 warnings, 239 lines checked

Your patch has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.
Checking PATCH 44/49: spapr: Add ibm, max-associativity-domains property...
Checking PATCH 45/49: ppc: e500: switch E500 based machines to full machine 
definition...
Checking PATCH 46/49: spapr: Support ibm, dynamic-memory-v2 property...
Checking PATCH 47/49: target/ppc: Don't bother with MSR_EP in 
cpu_ppc_set_papr()...
Checking PATCH 48/49: spapr: Set compatibility mode before the rest of 
spapr_cpu_reset()...
Checking PATCH 49/49: Clear mem_path if we fall back to anonymous RAM 
allocation...
=== OUTPUT END ===

Test command exited with code: 1


---
Email generated automatically by Patchew [http://patchew.org/].
Please send your feedback to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]