qemu-ppc
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-ppc] [PATCH for-1.2 v7 00/14] pci_host: Convert to QOM


From: Andreas Färber
Subject: [Qemu-ppc] [PATCH for-1.2 v7 00/14] pci_host: Convert to QOM
Date: Mon, 20 Aug 2012 19:07:55 +0200

Hello Anthony,

Here's the merged version of the series making pci_host a first-class QOM type.

Conflicts were in the spapr_pci patch (suggest to fully re-review that one) and
in the derive-from patch (additional/changed cast locations, rather trivial).

Regards,
Andreas

Cc: Anthony Liguori <address@hidden>
Cc: Alexander Graf <address@hidden>
Cc: qemu-ppc <address@hidden>
Cc: Alexey Kardashevskiy <address@hidden>
Cc: David Gibson <address@hidden>

Cc: Michael S. Tsirkin <address@hidden>
Cc: Wanpeng Li <address@hidden>
Cc: Jason Baron <address@hidden>

v6 -> v7:
* spapr_pci: Resolve conflicts with ppc PULL in hw/spapr{.c,_pci.[hc]} due to
  MSI support and another busdev fix attempt.

v5 -> v6:
* spapr_pci: Eliminate inline PCI_HOST_BRIDGE(), fix "phb" misnomer (Anthony).
* spapr_pci: Eliminate inline BUS().
* unin_pci: Remain explicit&consistent about type of opaque argument in patch 
14.
* patch 13: no longer mention struct changes diffused into earlier/later 
patches.

v4 -> v5:
* Resolved PCI_HOST_BRIDGE(s)->bus usage in alpha_typhoon (forgotten in v4).
* Update Wanpeng's email address in SoB to avoid bounces.
* Leave out MAINTAINERS additions, still valid but no ack from Alex yet and
  open question from Peter on ordering.

v3 -> v4:
* Moved spapr_pci.c:register_types() rename to later dedicated spapr_pci patch.
* Added proposed patches for related MAINTAINERS machine entries w/ PHB files.
Anthony requested the QOM cast discussion to be held elsewhere, so no change.

v2 -> v3:
* Renamed PCI_HOST to PCI_HOST_BRIDGE, suggested by mst.
* Split off const changes to clarify the name/parent changes.
* Split off cleanups per host bridge.
* Prepared and enforced QOM-style field access through explicit types.

v1 -> v2:
* Converted remaining PCI host bridges to new type.

Andreas Färber (14):
  pci: Make host bridge TypeInfos const
  alpha_typhoon: QOM'ify Typhoon PCI host bridge
  bonito: QOM'ify Bonito PCI host bridge
  dec_pci: QOM'ify DEC 21154 PCI-PCI bridge
  grackle_pci: QOM'ify Grackle PCI host bridge
  gt64xxx: QOM'ify GT64120 PCI host bridge
  ppc4xx_pci: QOM'ify ppc4xx PCI host bridge
  ppce500_pci: QOM'ify e500 PCI host bridge
  prep_pci: QOM'ify Raven PCI host bridge
  spapr_pci: QOM'ify sPAPR PCI host bridge
  unin_pci: QOM'ify UniNorth PCI host bridges
  pci_host: Turn into SysBus-derived QOM type
  pci: Derive PCI host bridges from TYPE_PCI_HOST_BRIDGE
  pci: Tidy up PCI host bridges

 hw/alpha_typhoon.c |   26 +++++---
 hw/bonito.c        |  152 +++++++++++++++++++++++++++-----------------
 hw/dec_pci.c       |   31 +++++----
 hw/dec_pci.h       |    2 +
 hw/grackle_pci.c   |   65 +++++++++----------
 hw/gt64xxx.c       |   67 +++++++++++--------
 hw/pci_host.c      |   12 ++++
 hw/pci_host.h      |    5 ++
 hw/piix_pci.c      |   22 ++++---
 hw/ppc440_bamboo.c |    3 +-
 hw/ppc4xx.h        |    2 +
 hw/ppc4xx_pci.c    |   27 +++++---
 hw/ppc_mac.h       |    1 +
 hw/ppc_prep.c      |    4 +-
 hw/ppce500_pci.c   |   24 ++++---
 hw/prep_pci.c      |   33 ++++++----
 hw/spapr.c         |    7 +-
 hw/spapr_pci.c     |   94 ++++++++++++++-------------
 hw/spapr_pci.h     |    7 ++-
 hw/unin_pci.c      |  181 +++++++++++++++++++++++++++-------------------------
 20 files changed, 439 insertions(+), 326 deletions(-)

-- 
1.7.7




reply via email to

[Prev in Thread] Current Thread [Next in Thread]