[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-discuss] configure fails with whpx enabled on msys2 w64 build proc

From: Dominique Fuchs
Subject: [Qemu-discuss] configure fails with whpx enabled on msys2 w64 build process
Date: Tue, 01 May 2018 11:42:56 +0200

Hi everyone,

I’m actually trying to compile qemu in an msys2 setup (as it seems to be the 
preferred way for native builds 
https://wiki.qemu.org/Hosts/W32#Native_builds_with_MSYS2) to use it with the 
just introduced whpx API by Windows 17134. 

I’m running

$ ./configure --enable-gtk --enable-sdl --enable-whpx --enable-hax

But only get 

ERROR: User requested feature WinHvPlatform
       configure was not able to find it.
       WinHvEmulation is not installed

as a result. I’m using the RTM of the new W10 version (17134.5) as well as the 
RTM of the corresponding SDK (17134.12). I double checked the include path 
(also through inheriting $PATH and $INCLUDE in msys2, the SDK Folders with the 
header files are definitiely reachable) and also tried specifying the SDK 
directly because it wasn’t clear to me from docs if this is neccessary:

$ ./configure --enable-gtk --enable-sdl --enable-whpx --enable-hax 

However, same result. 

What am I missing? Anyone able to give me a hint? I’m using the stable 2.12 
release tarball from git for this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]