qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v2] linux-user: rename gettid() to sys_gettid()


From: no-reply
Subject: Re: [Qemu-devel] [PATCH v2] linux-user: rename gettid() to sys_gettid() to avoid clash with glibc
Date: Wed, 20 Mar 2019 05:30:00 -0700 (PDT)

Patchew URL: https://patchew.org/QEMU/address@hidden/



Hi,

This series seems to have some coding style problems. See output below for
more information:

Message-id: address@hidden
Subject: [Qemu-devel] [PATCH v2] linux-user: rename gettid() to sys_gettid() to 
avoid clash with glibc
Type: series

=== TEST SCRIPT BEGIN ===
#!/bin/bash
git rev-parse base > /dev/null || exit 0
git config --local diff.renamelimit 0
git config --local diff.renames True
git config --local diff.algorithm histogram
./scripts/checkpatch.pl --mailback base..
=== TEST SCRIPT END ===

Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
From https://github.com/patchew-project/qemu
 * [new tag]               patchew/address@hidden -> patchew/address@hidden
Switched to a new branch 'test'
d90b5f3892 linux-user: rename gettid() to sys_gettid() to avoid clash with glibc

=== OUTPUT BEGIN ===
ERROR: open brace '{' following function declarations go on the next line
#45: FILE: linux-user/syscall.c:253:
+static int sys_gettid(void) {

ERROR: open brace '{' following function declarations go on the next line
#52: FILE: linux-user/syscall.c:259:
+static int sys_gettid(void) {

total: 2 errors, 0 warnings, 42 lines checked

Commit d90b5f3892f5 (linux-user: rename gettid() to sys_gettid() to avoid clash 
with glibc) has style problems, please review.  If any of these errors
are false positives report them to the maintainer, see
CHECKPATCH in MAINTAINERS.
=== OUTPUT END ===

Test command exited with code: 1


The full log is available at
http://patchew.org/logs/address@hidden/testing.checkpatch/?type=message.
---
Email generated automatically by Patchew [https://patchew.org/].
Please send your feedback to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]