qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/9] qom/user-creatable: add a few helper macros


From: Eduardo Habkost
Subject: Re: [Qemu-devel] [PATCH 1/9] qom/user-creatable: add a few helper macros
Date: Tue, 30 Oct 2018 20:07:17 -0300
User-agent: Mutt/1.9.2 (2017-12-15)

On Tue, Oct 30, 2018 at 03:22:43PM +0100, Igor Mammedov wrote:
> On Tue, 30 Oct 2018 13:26:40 +0400
> Marc-André Lureau <address@hidden> wrote:
> 
> > Hi
> > 
> > On Tue, Oct 30, 2018 at 5:37 AM Eduardo Habkost <address@hidden> wrote:
> > >
> > > On Mon, Oct 29, 2018 at 10:56:57AM +0100, Igor Mammedov wrote:  
> > > > On Fri, 26 Oct 2018 12:13:21 -0300
> > > > Eduardo Habkost <address@hidden> wrote:
> > > >  
> > > > > On Mon, Oct 22, 2018 at 03:33:30PM +0100, Igor Mammedov wrote:  
> > > > > > On Wed, 12 Sep 2018 16:55:23 +0400
> > > > > > Marc-André Lureau <address@hidden> wrote:
> > > > > >  
> > > > > > > Improve a bit code readability.
> > > > > > >
> > > > > > > Signed-off-by: Marc-André Lureau <address@hidden>
> > > > > > > ---
> > > > > > >  include/qom/object_interfaces.h | 4 ++++
> > > > > > >  qom/object.c                    | 4 ++--
> > > > > > >  qom/object_interfaces.c         | 9 +++------
> > > > > > >  3 files changed, 9 insertions(+), 8 deletions(-)
> > > > > > >
> > > > > > > diff --git a/include/qom/object_interfaces.h 
> > > > > > > b/include/qom/object_interfaces.h
> > > > > > > index 4d513fb329..46b0861457 100644
> > > > > > > --- a/include/qom/object_interfaces.h
> > > > > > > +++ b/include/qom/object_interfaces.h
> > > > > > > @@ -9,9 +9,13 @@
> > > > > > >  #define USER_CREATABLE_CLASS(klass) \
> > > > > > >       OBJECT_CLASS_CHECK(UserCreatableClass, (klass), \
> > > > > > >                          TYPE_USER_CREATABLE)
> > > > > > > +#define IS_USER_CREATABLE_CLASS(klass) \
> > > > > > > +    object_class_dynamic_cast(OBJECT_CLASS(oc), 
> > > > > > > TYPE_USER_CREATABLE)
> > > > > > >  #define USER_CREATABLE_GET_CLASS(obj) \
> > > > > > >       OBJECT_GET_CLASS(UserCreatableClass, (obj), \
> > > > > > >                        TYPE_USER_CREATABLE)
> > > > > > > +#define IS_USER_CREATABLE(obj) \
> > > > > > > +    object_dynamic_cast(OBJECT(obj), TYPE_USER_CREATABLE)
> > > > > > >  #define USER_CREATABLE(obj) \
> > > > > > >       INTERFACE_CHECK(UserCreatable, (obj), \
> > > > > > >                       TYPE_USER_CREATABLE)
> > > > > > > diff --git a/qom/object.c b/qom/object.c
> > > > > > > index 75d1d48944..0703e8e4ff 100644
> > > > > > > --- a/qom/object.c
> > > > > > > +++ b/qom/object.c
> > > > > > > @@ -424,7 +424,7 @@ void object_initialize_childv(Object 
> > > > > > > *parentobj, const char *propname,
> > > > > > >          goto out;
> > > > > > >      }
> > > > > > >
> > > > > > > -    if (object_dynamic_cast(obj, TYPE_USER_CREATABLE)) {
> > > > > > > +    if (IS_USER_CREATABLE(obj)) {
> > > > > > >          user_creatable_complete(obj, &local_err);
> > > > > > >          if (local_err) {
> > > > > > >              object_unparent(obj);
> > > > > > > @@ -605,7 +605,7 @@ Object *object_new_with_propv(const char 
> > > > > > > *typename,
> > > > > > >          goto error;
> > > > > > >      }
> > > > > > >
> > > > > > > -    if (object_dynamic_cast(obj, TYPE_USER_CREATABLE)) {
> > > > > > > +    if (IS_USER_CREATABLE(obj)) {
> > > > > > >          user_creatable_complete(obj, &local_err);
> > > > > > >          if (local_err) {
> > > > > > >              object_unparent(obj);
> > > > > > > diff --git a/qom/object_interfaces.c b/qom/object_interfaces.c
> > > > > > > index 72b97a8bed..e3084bc04a 100644
> > > > > > > --- a/qom/object_interfaces.c
> > > > > > > +++ b/qom/object_interfaces.c
> > > > > > > @@ -10,18 +10,15 @@
> > > > > > >
> > > > > > >  void user_creatable_complete(Object *obj, Error **errp)
> > > > > > >  {
> > > > > > > -
> > > > > > >      UserCreatableClass *ucc;
> > > > > > > -    UserCreatable *uc =
> > > > > > > -        (UserCreatable *)object_dynamic_cast(obj, 
> > > > > > > TYPE_USER_CREATABLE);
> > > > > > >
> > > > > > > -    if (!uc) {
> > > > > > > +    if (!IS_USER_CREATABLE(obj)) {
> > > > > > >          return;
> > > > > > >      }
> > > > > > >
> > > > > > > -    ucc = USER_CREATABLE_GET_CLASS(uc);
> > > > > > > +    ucc = USER_CREATABLE_GET_CLASS(obj);
> > > > > > >      if (ucc->complete) {
> > > > > > > -        ucc->complete(uc, errp);
> > > > > > > +        ucc->complete(USER_CREATABLE(obj), errp);  
> > > > > >                          ^^^
> > > > > > even though function becomes more concise,
> > > > > > this will call expensive dynamic cast 2nd time (IS_USER_CREATABLE 
> > > > > > was the 1st and discarded)
> > > > > > so I'm not sure is a good idea to regress startup time for 
> > > > > > readability.  
> > 
> > I hope it's not measurable, unless we create billions of objects. Do
> > you want some figures?
> I recall penalty was big enough for QEMU, that we added qom debug option,
> in case of -object, the cost could be multiplied by hundreds

This sounds like premature optimization.  Did you measure how
many nanoseconds we're saving per -object option?


> > > > > (INTERFACE_CHECK is a nop if CONFIG_QOM_CAST_DEBUG is not
> > > > > enabled, so I don't understand how it would regress startup time.  
> > > > Isn't it enabled by default though?
> > > > Maybe we should flip default to disabled then cast should be ok and 
> > > > enable it
> > > > when generic '--debug' is enabled.  
> > >
> > > This is called only once for each -object option.  Even if QOM
> > > debugging is enabled by default I don't see why it wouldn't be OK
> > > to call object_dynamic_cast_assert() here.  
> > 
> > Yes, imho it's very marginal. Thus I would value more readability.
> Probably not marginal for folks who are trying to reduce every
> tiny bit of start up time.

These people should be disabling QOM debugging, then.

> 
> Considering readablity change here doesn't really make a difference,
> I'd pick performance. i.e. do cast and then reuse result later.
>  
> > Alternatively, we can consider replacing
> > ucc->complete(USER_CREATABLE(obj), errp); by
> > ucc->complete((UserCreatable*)obj, errp); to get back to the same
> > number of dynamic_cast calls.
> Unsafe casts (foo*) typically frowned upon but it should be safe
> since one gets here after IS_USER_CREATABLE check, so I don't really
> care in this case. But I'd drop user_creatable_complete() hunk,
> so that original cast result is being reused.

Please don't do that.  Readability, safety, and consistency are
more important.  For the few users where QOM debugging has a
measurable performance impact, we already have a mechanism to
disable it.

-- 
Eduardo



reply via email to

[Prev in Thread] Current Thread [Next in Thread]