qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH 00/32] qmp: Fixes and cleanups around OOB commands


From: Markus Armbruster
Subject: [Qemu-devel] [PATCH 00/32] qmp: Fixes and cleanups around OOB commands
Date: Mon, 2 Jul 2018 18:21:46 +0200

We're trying to get the out-of-band execution feature ready.  This
series fixes a number of issues, and marks a design flaw FIXME.  More
work is needed.

Markus Armbruster (32):
  qmp: Say "out-of-band" instead of "Out-Of-Band"
  monitor: Spell "I/O thread" consistently in comments
  docs/interop/qmp: Improve OOB documentation
  qmp: Document COMMAND_DROPPED design flaw
  qmp: Get rid of x-oob-test command
  tests/qmp-test: Test in-band command doesn't overtake
  qmp: Make "id" optional again even in "oob" monitors
  tests/test-qga: Demonstrate the guest-agent ignores "id"
  qmp qemu-ga: Revert change that accidentally made qemu-ga accept "id"
  tests/test-qga: Demonstrate the guest-agent ignores "control"
  qmp qemu-ga: Fix qemu-ga not to accept "control"
  qmp: Redo how the client requests out-of-band execution
  qmp: Revert change to handle_qmp_command tracepoint
  qmp: Always free QMPRequest with qmp_request_free()
  qmp: Simplify code around monitor_qmp_dispatch_one()
  tests/qmp-test: Demonstrate QMP errors jumping the queue
  qmp: Don't let malformed in-band commands jump the queue
  qmp: Don't let JSON errors jump the queue
  monitor: Rename use_io_thr to use_io_thread
  monitor: Peel off @mon_global wrapper
  qobject: New qdict_from_jsonf_nofail()
  qmp: De-duplicate error response building
  qmp: Use QDict * instead of QObject * for response objects
  qmp: Replace monitor_json_emitter{,raw}() by
    qmp_{queue,send}_response()
  qmp: Replace get_qmp_greeting() by qmp_greeting()
  qmp: Simplify monitor_qmp_respond()
  qmp: Add some comments around null responses
  qmp: Switch timestamp_put() to qdict_from_jsonf_nofail()
  qobject: Let qobject_from_jsonf() fail instead of abort
  qmp: Clean up capability negotiation after commit 02130314d8c
  monitor: Improve some comments
  qapi: Polish command flags documentation in qapi-code-gen.txt

 docs/devel/qapi-code-gen.txt            |  63 ++-
 docs/interop/qmp-intro.txt              |  13 +-
 docs/interop/qmp-spec.txt               |  81 ++--
 include/qapi/qmp/dispatch.h             |   6 +-
 include/qapi/qmp/qjson.h                |   2 +
 monitor.c                               | 507 ++++++++++--------------
 qapi/misc.json                          |  23 +-
 qapi/qmp-dispatch.c                     |  97 ++---
 qapi/qmp-event.c                        |  10 +-
 qga/main.c                              |  18 +-
 qmp.c                                   |  16 -
 qobject/qjson.c                         |  23 +-
 tests/qapi-schema/qapi-schema-test.json |   2 +-
 tests/qmp-test.c                        | 103 +++--
 tests/test-qga.c                        |  34 ++
 tests/test-qmp-cmds.c                   |  23 +-
 16 files changed, 499 insertions(+), 522 deletions(-)

-- 
2.17.1




reply via email to

[Prev in Thread] Current Thread [Next in Thread]