qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v20 0/7] Virtio-balloon Enhancement


From: Wei Wang
Subject: Re: [Qemu-devel] [PATCH v20 0/7] Virtio-balloon Enhancement
Date: Wed, 20 Dec 2017 18:34:36 +0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.7.0

On 12/19/2017 10:05 PM, Tetsuo Handa wrote:
Wei Wang wrote:
ChangeLog:
v19->v20:
1) patch 1: xbitmap
        - add __rcu to "void **slot";
        - remove the exceptional path.
2) patch 3: xbitmap
        - DeveloperNotes: add an item to comment that the current bit range
          related APIs operating on extremely large ranges (e.g.
           [0, ULONG_MAX)) will take too long time. This can be optimized in
          the future.
        - remove the exceptional path;
        - remove xb_preload_and_set();
        - reimplement xb_clear_bit_range to make its usage close to
          bitmap_clear;
        - rename xb_find_next_set_bit to xb_find_set, and re-implement it
          in a style close to find_next_bit;
        - rename xb_find_next_zero_bit to xb_find_clear, and re-implement
          it in a stytle close to find_next_zero_bit;
        - separate the implementation of xb_find_set and xb_find_clear for
          the convenience of future updates.
Removing exceptional path made this patch easier to read.
But what I meant is

   Can you eliminate exception path and fold all xbitmap patches into one, and
   post only one xbitmap patch without virtio-balloon changes?

.

I still think we don't need xb_preload()/xb_preload_end().

Why would you think preload is not needed?

The bitmap is allocated via preload "bitmap = this_cpu_cmpxchg(ida_bitmap, NULL, bitmap);", this allocated bitmap would be used in xb_set_bit().


I think xb_find_set() has a bug in !node path.

I think we can probably remove the "!node" path for now. It would be good to get the fundamental part in first, and leave optimization to come as separate patches with corresponding test cases in the future.

Best,
Wei



reply via email to

[Prev in Thread] Current Thread [Next in Thread]