qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v18 05/10] xbitmap: add more operations


From: Tetsuo Handa
Subject: Re: [Qemu-devel] [PATCH v18 05/10] xbitmap: add more operations
Date: Fri, 1 Dec 2017 22:02:01 +0900

Wei Wang wrote:
> On 11/30/2017 06:34 PM, Tetsuo Handa wrote:
> > Wei Wang wrote:
> >> + * @start: the start of the bit range, inclusive
> >> + * @end: the end of the bit range, inclusive
> >> + *
> >> + * This function is used to clear a bit in the xbitmap. If all the bits 
> >> of the
> >> + * bitmap are 0, the bitmap will be freed.
> >> + */
> >> +void xb_clear_bit_range(struct xb *xb, unsigned long start, unsigned long 
> >> end)
> >> +{
> >> +  struct radix_tree_root *root = &xb->xbrt;
> >> +  struct radix_tree_node *node;
> >> +  void **slot;
> >> +  struct ida_bitmap *bitmap;
> >> +  unsigned int nbits;
> >> +
> >> +  for (; start < end; start = (start | (IDA_BITMAP_BITS - 1)) + 1) {
> >> +          unsigned long index = start / IDA_BITMAP_BITS;
> >> +          unsigned long bit = start % IDA_BITMAP_BITS;
> >> +
> >> +          bitmap = __radix_tree_lookup(root, index, &node, &slot);
> >> +          if (radix_tree_exception(bitmap)) {
> >> +                  unsigned long ebit = bit + 2;
> >> +                  unsigned long tmp = (unsigned long)bitmap;
> >> +
> >> +                  nbits = min(end - start + 1, BITS_PER_LONG - ebit);
> > "nbits = min(end - start + 1," seems to expect that start == end is legal
> > for clearing only 1 bit. But this function is no-op if start == end.
> > Please clarify what "inclusive" intended.
> 
> If xb_clear_bit_range(xb,10,10), then it is effectively the same as 
> xb_clear_bit(10). Why would it be illegal?
> 
> "@start inclusive" means that the @start will also be included to be 
> cleared.

If start == end is legal,

   for (; start < end; start = (start | (IDA_BITMAP_BITS - 1)) + 1) {

makes this loop do nothing because 10 < 10 is false.



> 
> >
> >> +static inline __always_inline void bitmap_clear(unsigned long *map,
> >> +                                          unsigned int start,
> >> +                                          unsigned int nbits)
> >> +{
> >> +  if (__builtin_constant_p(nbits) && nbits == 1)
> >> +          __clear_bit(start, map);
> >> +  else if (__builtin_constant_p(start & 7) && IS_ALIGNED(start, 8) &&
> >> +           __builtin_constant_p(nbits & 7) && IS_ALIGNED(nbits, 8))
> > It looks strange to apply __builtin_constant_p test to variables after "& 
> > 7".
> >
> 
> I think this is normal - if the variables are known at compile time, the 
> calculation will be done at compile time (termed constant folding).

I think that

+       else if (__builtin_constant_p(start) && IS_ALIGNED(start, 8) &&
+                __builtin_constant_p(nbits) && IS_ALIGNED(nbits, 8))

is more readable.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]