qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH] qom: add helpers REGISTER_STATIC_TYPE[S]()


From: Igor Mammedov
Subject: Re: [Qemu-devel] [PATCH] qom: add helpers REGISTER_STATIC_TYPE[S]()
Date: Tue, 3 Oct 2017 17:38:24 +0200

On Tue, 3 Oct 2017 10:29:22 -0300
Philippe Mathieu-Daudé <address@hidden> wrote:

> Hi Igor,
> 
> On 10/03/2017 09:14 AM, Igor Mammedov wrote:
> > it will help to remove code duplication in places
> > that currently open code registration of static
> > type[s] and remove necessity to declare function
> > for type_init() to call, when only static types
> > need to be registered.
> > 
> > Signed-off-by: Igor Mammedov <address@hidden>
> > ---
> > I'm going to use it for CPU types in followup patches
> > 
> > CC: address@hidden
> > ---
> >  include/qemu/module.h | 10 ++++++++++
> >  include/qom/object.h  | 10 ++++++++++
> >  qom/object.c          |  9 +++++++++
> >  3 files changed, 29 insertions(+)
> > 
> > diff --git a/include/qemu/module.h b/include/qemu/module.h
> > index 56dd218..60dd632 100644
> > --- a/include/qemu/module.h
> > +++ b/include/qemu/module.h
> > @@ -52,6 +52,16 @@ typedef enum {
> >  #define type_init(function) module_init(function, MODULE_INIT_QOM)
> >  #define trace_init(function) module_init(function, MODULE_INIT_TRACE)
> >  
> > +#define REGISTER_STATIC_TYPES(t, nr)                                       
> >  \  
> 
> ok
> 
> > +static void do_qemu_init_ ## t(void)                                       
> >  \
> > +{                                                                          
> >  \
> > +    type_register_static_array(t, nr);                                     
> >  \
> > +}                                                                          
> >  \
> > +type_init(do_qemu_init_ ## t)
> > +
> > +#define REGISTER_STATIC_TYPE(t)                                            
> >  \  
> 
> eh why not...
> 
> What's your plan for your "generalize parsing of cpu_model (2)" series?
> re-post the whole? If you just change this macro you can keep my R-b for it.
It looks like I'll have to amend and repost series.
I'd prefer to keep type_init_from_array() patch for now as it does what's need
and in line with current type_init().
But it seems Eduardo doesn't like it and want's a more generalized way
to handle typeinfo array or single typeinfo.
So most likely I'll end-up keeping *_cpu_register_types() functions and call
type_register_static_array() from there replacing only loops.

> 
> > +    REGISTER_STATIC_TYPES(t, 1)
> > +
> >  #define block_module_load_one(lib) module_load_one("block-", lib)
> >  
> >  void register_module_init(void (*fn)(void), module_init_type type);
> > diff --git a/include/qom/object.h b/include/qom/object.h
> > index f3e5cff..17fcadd 100644
> > --- a/include/qom/object.h
> > +++ b/include/qom/object.h
> > @@ -789,6 +789,16 @@ Type type_register_static(const TypeInfo *info);
> >  Type type_register(const TypeInfo *info);
> >  
> >  /**
> > + * type_register_static_array:
> > + * @infos: The array of the new type #TypeInfo structures.
> > + * @nr_infos: number of entries in @infos
> > + *
> > + * @infos and all of the strings it points to should exist for the life 
> > time
> > + * that the type is registered.
> > + */
> > +void type_register_static_array(const TypeInfo *infos, int nr_infos);
> > +
> > +/**
> >   * object_class_dynamic_cast_assert:
> >   * @klass: The #ObjectClass to attempt to cast.
> >   * @typename: The QOM typename of the class to cast to.
> > diff --git a/qom/object.c b/qom/object.c
> > index 3e18537..40b1729 100644
> > --- a/qom/object.c
> > +++ b/qom/object.c
> > @@ -151,6 +151,15 @@ TypeImpl *type_register_static(const TypeInfo *info)
> >      return type_register(info);
> >  }
> >  
> > +void type_register_static_array(const TypeInfo *infos, int nr_infos)
> > +{
> > +    int i;
> > +
> > +    for (i = 0; i < nr_infos; i++) {
> > +        assert(type_register_static(&infos[i]));
> > +    }
> > +}  
> 
> Reviewed-by: Philippe Mathieu-Daudé <address@hidden>
> 
> > +
> >  static TypeImpl *type_get_by_name(const char *name)
> >  {
> >      if (name == NULL) {
> >   
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]