qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 23/31] ram: Move migration_bitmap_rcu into RAMSt


From: Juan Quintela
Subject: Re: [Qemu-devel] [PATCH 23/31] ram: Move migration_bitmap_rcu into RAMState
Date: Mon, 20 Mar 2017 21:10:23 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

"Dr. David Alan Gilbert" <address@hidden> wrote:
> * Juan Quintela (address@hidden) wrote:
>> Once there, rename the type to be shorter.
>> 
>> Signed-off-by: Juan Quintela <address@hidden>
>> ---
>>  migration/ram.c | 79 
>> ++++++++++++++++++++++++++++++---------------------------
>>  1 file changed, 42 insertions(+), 37 deletions(-)
>> 
>> diff --git a/migration/ram.c b/migration/ram.c
>> index c14293c..d39d185 100644
>> --- a/migration/ram.c
>> +++ b/migration/ram.c
>> @@ -132,6 +132,19 @@ out:
>>      return ret;
>>  }
>>  
>> +struct RAMBitmap {
>> +    struct rcu_head rcu;
>> +    /* Main migration bitmap */
>> +    unsigned long *bmap;
>> +    /* bitmap of pages that haven't been sent even once
>> +     * only maintained and used in postcopy at the moment
>> +     * where it's used to send the dirtymap at the start
>> +     * of the postcopy phase
>> +     */
>> +    unsigned long *unsentmap;
>> +};
>> +typedef struct RAMBitmap RAMBitmap;
>> +
>
> I'm OK with this; although I can see the idea of naming it BitmapRcu,
> given that the actual bmap is inside that and most of the rest of the type
> is just the rcu wrapper.

It is the type, and now it also has the unsentmap.

  atomic_rcu_read(&ram_state.bitmap_rcu)->bmap)

ends  getting really long quite fast "p"

> Reviewed-by: Dr. David Alan Gilbert <address@hidden>

Thanks, Juan.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]