qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 00/11] virtio migration: simplify vmstate helper


From: Paolo Bonzini
Subject: Re: [Qemu-devel] [PATCH 00/11] virtio migration: simplify vmstate helper
Date: Fri, 30 Sep 2016 17:02:13 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.3.0


On 30/09/2016 16:19, Halil Pasic wrote:
> As a part of the long term  effort to convert migration to vmstate the
> migration of virtio devices was recently partially switched to vmstate
> starting with the outer layer (commit 5943124cc "virtio: Migration
> helper function and macro" and the subsequent "virtio-*: Wrap in
> vmstate" commits). This was done by introducing a vmstate based wrapper
> driving the well know virtio migration process. As this transition is
> still in progress, some synergies were left unexploited, and some things
> can be expressed in a more vmstatish way.

Another useful thing to do is to move code out of virtio_load and into a
post_load callback of vmstate_virtio.

Paolo

> Let us simplify a couple of things and get rid of some code duplication.
> 
> Did only a couple of smoke tests. Comprehensive testing is still to be done.
> 
> Halil Pasic (11):
>   virtio: add VIRTIO_DEF_DEVICE_VMSD macro
>   virtio-blk: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio-net: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio-9p: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio-serial: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio-gpu: do not use VMSTATE_VIRTIO_DEVICE
>   virtio-input: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio-scsi: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio-balloon: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio-rng: convert to VIRTIO_DEF_DEVICE_VMSD
>   virtio: remove unused VMSTATE_VIRTIO_DEVICE
> 
>  hw/9pfs/virtio-9p-device.c  |  7 +------
>  hw/block/virtio-blk.c       | 17 +----------------
>  hw/char/virtio-serial-bus.c |  8 +-------
>  hw/display/virtio-gpu.c     | 39 +++++++++++++++++++++++++++------------
>  hw/input/virtio-input.c     | 13 +++----------
>  hw/net/virtio-net.c         | 32 +++++++++++---------------------
>  hw/scsi/virtio-scsi.c       | 18 +-----------------
>  hw/virtio/virtio-balloon.c  |  7 +------
>  hw/virtio/virtio-rng.c      | 10 ++--------
>  hw/virtio/virtio.c          | 11 ++++++++++-
>  include/hw/virtio/virtio.h  | 31 ++++++++++++++++++-------------
>  11 files changed, 76 insertions(+), 117 deletions(-)
> 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]