qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH 1/3] target-i386: Coding style fix on x86_cpuid_set_


From: Eduardo Habkost
Subject: [Qemu-devel] [PATCH 1/3] target-i386: Coding style fix on x86_cpuid_set_vendor()
Date: Fri, 24 Apr 2015 16:37:30 -0300

checkpatch.pl doesn't like the extra spaces inside the square brackets,
but the alignment makes the code easier to read. Add a "+ 0" to keep
alignment while making checkpatch.pl happy.

Signed-off-by: Eduardo Habkost <address@hidden>
---
 target-i386/cpu.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/target-i386/cpu.c b/target-i386/cpu.c
index 07465ac..11da4b5 100644
--- a/target-i386/cpu.c
+++ b/target-i386/cpu.c
@@ -1640,7 +1640,7 @@ static void x86_cpuid_set_vendor(Object *obj, const char 
*value,
     env->cpuid_vendor2 = 0;
     env->cpuid_vendor3 = 0;
     for (i = 0; i < 4; i++) {
-        env->cpuid_vendor1 |= ((uint8_t)value[i    ]) << (8 * i);
+        env->cpuid_vendor1 |= ((uint8_t)value[i + 0]) << (8 * i);
         env->cpuid_vendor2 |= ((uint8_t)value[i + 4]) << (8 * i);
         env->cpuid_vendor3 |= ((uint8_t)value[i + 8]) << (8 * i);
     }
-- 
2.1.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]