qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH v3 for-2.3 10/24] hw/apci: add _PRT method for e


From: Michael S. Tsirkin
Subject: Re: [Qemu-devel] [PATCH v3 for-2.3 10/24] hw/apci: add _PRT method for extra PCI root busses
Date: Thu, 5 Mar 2015 23:17:52 +0100

On Thu, Mar 05, 2015 at 11:55:34PM +0200, Marcel Apfelbaum wrote:
> On 03/05/2015 09:52 PM, Michael S. Tsirkin wrote:
> >On Thu, Mar 05, 2015 at 04:55:08PM +0200, Marcel Apfelbaum wrote:
> >>Signed-off-by: Marcel Apfelbaum <address@hidden>
> >>---
> >>  hw/i386/acpi-build.c | 78 
> >> ++++++++++++++++++++++++++++++++++++++++++++++++++++
> >>  1 file changed, 78 insertions(+)
> >>
> >>diff --git a/hw/i386/acpi-build.c b/hw/i386/acpi-build.c
> >>index e5709e8..f0401d2 100644
> >>--- a/hw/i386/acpi-build.c
> >>+++ b/hw/i386/acpi-build.c
> >>@@ -664,6 +664,83 @@ static void build_append_pci_bus_devices(Aml 
> >>*parent_scope, PCIBus *bus,
> >>      aml_append(parent_scope, method);
> >>  }
> >>
> >>+static Aml *build_prt(void)
> >>+{
> >>+    Aml *method, *pkg, *if_ctx, *while_ctx;
> >>+
> >>+    method = aml_method("_PRT", 0);
> >>+
> >>+    aml_append(method, aml_store(aml_package(128), aml_local(0)));
> >>+    aml_append(method, aml_store(aml_int(0), aml_local(1)));
> >>+    while_ctx = aml_while(aml_lless(aml_local(1), aml_int(128)));
> >>+    {
> >>+        aml_append(while_ctx,
> >>+            aml_store(aml_shiftright(aml_local(1), aml_int(2)), 
> >>aml_local(2)));
> >>+        aml_append(while_ctx,
> >>+            aml_store(aml_and(aml_add(aml_local(1), aml_local(2)), 
> >>aml_int(3)),
> >>+                      aml_local(3)));
> >>+
> >>+        if_ctx = aml_if(aml_equal(aml_local(3), aml_int(0)));
> >>+        {
> >>+            pkg = aml_package(4);
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_name("LNKD"));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(if_ctx, aml_store(pkg, aml_local(4)));
> >>+        }
> >>+        aml_append(while_ctx, if_ctx);
> >>+
> >>+        if_ctx = aml_if(aml_equal(aml_local(3), aml_int(1)));
> >>+        {
> >>+            pkg = aml_package(4);
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_name("LNKA"));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(if_ctx, aml_store(pkg, aml_local(4)));
> >>+        }
> >>+        aml_append(while_ctx, if_ctx);
> >>+
> >>+        if_ctx = aml_if(aml_equal(aml_local(3), aml_int(2)));
> >>+        {
> >>+            pkg = aml_package(4);
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_name("LNKB"));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(if_ctx, aml_store(pkg, aml_local(4)));
> >>+        }
> >>+        aml_append(while_ctx, if_ctx);
> >>+
> >>+        if_ctx = aml_if(aml_equal(aml_local(3), aml_int(3)));
> >>+        {
> >>+            pkg = aml_package(4);
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(pkg, aml_name("LNKC"));
> >>+            aml_append(pkg, aml_int(0));
> >>+            aml_append(if_ctx, aml_store(pkg, aml_local(4)));
> >>+        }
> >>+        aml_append(while_ctx, if_ctx);
> >>+
> >>+        aml_append(while_ctx,
> >>+            aml_store(aml_or(aml_shiftleft(aml_local(2), aml_int(16)),
> >>+                             aml_int(0xFFFF)),
> >>+                      aml_index(aml_local(4), aml_int(0))));
> >>+        aml_append(while_ctx,
> >>+            aml_store(aml_and(aml_local(1), aml_int(3)),
> >>+                      aml_index(aml_local(4), aml_int(1))));
> >>+        aml_append(while_ctx,
> >>+            aml_store(aml_local(4), aml_index(aml_local(0), 
> >>aml_local(1))));
> >>+        aml_append(while_ctx, aml_increment(aml_local(1)));
> >>+    }
> >>+    aml_append(method, while_ctx);
> >>+    aml_append(method, aml_return(aml_local(0)));
> >>+
> >>+    return method;
> >>+}
> >>+
> >
> >Pls improve readability of this code using comments, sub-functions and
> >local variables.
> It is the exact "copy" of the static aml code we had, witch by itself
> wasn't so nice, so it is so much I can do.

That one has *some* comments at least.
But yes, we can do better.

Duplication of code is also a problem.



> However, I'll try to improve it.
> 
> Thanks,
> Marcel
> 
> 
> >
> >
> >>  static void
> >>  build_ssdt(GArray *table_data, GArray *linker,
> >>             AcpiCpuInfo *cpu, AcpiPmInfo *pm, AcpiMiscInfo *misc,
> >>@@ -708,6 +785,7 @@ build_ssdt(GArray *table_data, GArray *linker,
> >>              aml_append(dev, aml_name_decl("_HID", aml_string("PNP0A03")));
> >>              aml_append(dev,
> >>                  aml_name_decl("_BBN", aml_int((uint8_t)bus_info->bus)));
> >>+            aml_append(dev, build_prt());
> >>              aml_append(scope, dev);
> >>              aml_append(ssdt, scope);
> >>          }
> >>--
> >>2.1.0



reply via email to

[Prev in Thread] Current Thread [Next in Thread]