qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] [PATCH v2 1/2] block: Rename BLOCK_OP_TYPE_REPLACE to BLOCK


From: Benoît Canet
Subject: [Qemu-devel] [PATCH v2 1/2] block: Rename BLOCK_OP_TYPE_REPLACE to BLOCK_OP_TYPE_MIRROR_REPLACE
Date: Mon, 22 Sep 2014 14:40:38 +0200

This operation blocker is really specific to the mirroring code so its name
should reflect this.

Signed-off-by: Benoît Canet <address@hidden>
---
 block.c               | 2 +-
 include/block/block.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/block.c b/block.c
index bcd952a..9a9f8a0 100644
--- a/block.c
+++ b/block.c
@@ -5912,7 +5912,7 @@ BlockDriverState *check_to_replace_node(const char 
*node_name, Error **errp)
         return NULL;
     }
 
-    if (bdrv_op_is_blocked(to_replace_bs, BLOCK_OP_TYPE_REPLACE, errp)) {
+    if (bdrv_op_is_blocked(to_replace_bs, BLOCK_OP_TYPE_MIRROR_REPLACE, errp)) 
{
         return NULL;
     }
 
diff --git a/include/block/block.h b/include/block/block.h
index 07d6d8e..10952ed 100644
--- a/include/block/block.h
+++ b/include/block/block.h
@@ -176,7 +176,7 @@ typedef enum BlockOpType {
     BLOCK_OP_TYPE_MIRROR,
     BLOCK_OP_TYPE_RESIZE,
     BLOCK_OP_TYPE_STREAM,
-    BLOCK_OP_TYPE_REPLACE,
+    BLOCK_OP_TYPE_MIRROR_REPLACE,
     BLOCK_OP_TYPE_MAX,
 } BlockOpType;
 
-- 
2.1.0




reply via email to

[Prev in Thread] Current Thread [Next in Thread]