qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 1/8] [PATCH RFC v3] s390-qemu: cpu hotplug - Def


From: Jason J. Herne
Subject: Re: [Qemu-devel] [PATCH 1/8] [PATCH RFC v3] s390-qemu: cpu hotplug - Define New SCLP Codes
Date: Mon, 16 Sep 2013 10:29:02 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130623 Thunderbird/17.0.7

On 09/16/2013 09:53 AM, Christian Borntraeger wrote:
On 05/09/13 13:25, Alexander Graf wrote:

On 01.08.2013, at 16:12, Jason J. Herne wrote:

From: "Jason J. Herne" <address@hidden>

Define new SCLP codes to improve code readability.

Signed-off-by: Jason J. Herne <address@hidden>
---
hw/s390x/sclp.c         |    2 +-
include/hw/s390x/sclp.h |    8 ++++++++
2 files changed, 9 insertions(+), 1 deletion(-)

diff --git a/hw/s390x/sclp.c b/hw/s390x/sclp.c
index 86d6ae0..cb53d7e 100644
--- a/hw/s390x/sclp.c
+++ b/hw/s390x/sclp.c
@@ -45,7 +45,7 @@ static void sclp_execute(SCCB *sccb, uint64_t code)
{
     S390SCLPDevice *sdev = get_event_facility();

-    switch (code) {
+    switch (code & SCLP_NO_CMD_PARM) {

switch (code & ~SCLP_CMD_PARM)

Or are the upper bits parm as well? In fact, what about the upper 32 bits?

As of now those are ignored by the sclp. So (code & SCLP_NO_CMD_PARM) seems
better to me.





What if I rename it to SCLP_CMD_CODE_MASK? This removes the negative from the name and keeps the same semantics.

--
-- Jason J. Herne (address@hidden)




reply via email to

[Prev in Thread] Current Thread [Next in Thread]