[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] Strange clock issues with Windows Server 2008 R2

From: David Weber
Subject: [Qemu-devel] Strange clock issues with Windows Server 2008 R2
Date: Fri, 30 Aug 2013 09:24:28 +0200
User-agent: KMail/4.11 (Linux/3.10.3-david; KDE/4.11.0; x86_64; ; )


we're experiencing some very strange clock issues with a Windows Server 2008R8 
which runs on a Gentoo Host with qemu 1.5.2 and Linux 3.11-rc7

The Windows Server is intended to be a terminalserver which serves desktops 
through RDP. When I start a session, everything works fine for some time (0:30 
to 1:30 hours) Then the windows clock just gets stuck and doesn't change at 
all any more. At this point every operation on the server gets sluggisch and 

To solve this problem I have to connect to qemu's vnc server, then the clock 
magically begins to run again and the server returns to a normal state.

The host is a NUMA system with 2 sockets. The guest is pinned to the first 
node. Clocksource on the host is HPET. Host CPUs are Intel Xeon E5645

I tried many "tricks" which you can find on the internet like setting:
bcdedit /set {default} USEPLATFORMCLOCK on
or using another ntp server on the guest.
I also tried many of the qemu/libvirt clock settings but all without any luck.

The current guest cmd line is:
/usr/bin/kvm -name xxx -S -machine pc-i440fx-1.5,accel=kvm,usb=off -cpu 
+monitor,+dtes64,+pclmuldq,+pbe,+tm,+ht,+ss,+acpi,+ds,+vme -m 8192 -realtime 
mlock=off -smp 4,sockets=4,cores=1,threads=1 -uuid 4ecd5ae5-8723-0985-
ea8f-32cf5156e8eb -no-user-config -nodefaults -chardev 
socket,id=charmonitor,path=/var/lib/libvirt/qemu/xxx.monitor,server,nowait -
mon chardev=charmonitor,id=monitor,mode=control -rtc 
base=localtime,driftfix=slew -no-kvm-pit-reinjection -no-shutdown -boot 
menu=off -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive 
file=/mnt/kvm-images/xxx,if=none,id=drive-virtio-disk0,format=raw,cache=none -
device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-
disk0,id=virtio-disk0,bootindex=1 -drive file=/mnt/kvm-images/isos/virtio-
win-0.1-65.iso,if=none,id=drive-ide0-1-0,readonly=on,format=raw,cache=none -
device ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev 
tap,fd=22,id=hostnet0,vhost=on,vhostfd=47 -device virtio-net-
pci,netdev=hostnet0,id=net0,mac=xxx,bus=pci.0,addr=0x3 -device usb-
tablet,id=input0 -vnc -vga std -device virtio-balloon-

On the host run many linux guests(which use kvmclock) and a few windows server 
2003 which don't have any clock issues.
Any help is greatly appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]